tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kitching Simon <Simon.Kitch...@orange.ch>
Subject RE: Problem loading Servlets in Netscape
Date Tue, 26 Sep 2000 18:02:29 GMT


> -----Original Message-----
> From:	Shravan Shashikant [SMTP:s0s7900@unix.tamu.edu]
> Sent:	Tuesday, September 26, 2000 7:51 PM
> To:	tomcat-user@jakarta.apache.org
> Subject:	Problem loading Servlets in Netscape
> 
> Hi everybody,
>   I am experiencing a peculiar problem.I have developed certain servlets
> which run on a tomcat/win 2000 envt.They run perfectly well when called
> from an IE browser but when called from Netscape,the html tags show up in
> the browser as if having opened the html document in notepad.
>  Any ideas whats happening?
> TIA,
> Shravan
	[Kitching Simon]  
	Well, your servlet appears to be running fine, 
	ie it is generating text output.

	I've found that Netscape is much fussier about 
	having correct HTML than IE is. If IE finds bad 
	html, it makes a guess at what you really meant, 
	and most of the time guesses right. Netscape,
	however, either presents an error message or 
	just outputs plain text.

	Therefore, my guess is that your servlet 
	is actually generating bad html (eg you forgot 
	to generate a <body> tag), and IE is
	silently fixing the page for you.

	Which (IE/Netscape) is the right approach 
	is open to debate. Certainly if IE reported 
	errors in html pages, there would be a 
	lot less invalid html around, and that would 
	lead to more consistent page rendering 
	between browsers.....

	Regards,

	Simon

Mime
View raw message