tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Raman <ara...@india-today.com>
Subject Re: Apache & Tomcat
Date Wed, 20 Sep 2000 11:15:15 GMT
the howto file mentions that u have to compile mod_jk.so ur self and
there is no pre compiled build available..
Anyway i suggest that u try and recompile it ..
1. cd /usr/local/jakarta-home/jakarta-tomcat/src/native/apache1.3
2. use apxs
apxs -o mod_jk.so -I /usr/local/jdk1.2.2/include -I \
/usr/local/jdk1.2.2/include/linux -I ../jk/ -c *.c ../jk/*.c 
3. copy the generated mod_jk.so file to /usr/local/libexec and restart
apache..
I hope this helps
Anand
On Wed, Sep 13, 2000 at 02:41:19PM -0500, Michael H. La Budde wrote:
>
>
>I downloaded, built, & installed the latest version of Apache (1.3.12) for 
>my Linux platform. In attempting to get it to serve the static content & 
>Tomcat to do the dynamic, I get the following error message when trying to 
>start Apache:
>
>Syntax error on line 8 of /opt/tomcat/conf/mod_jk.conf-auto:
>API module structure 'jk_module' in file /usr/local/apache/libexec/mod_jk.so
>is garbled - perhaps this is not an Apache module DSO?
>
>I'm using Tomcat 3.2beta3 and I've tried downloading mod_jk.so _several_ 
>times.
>
>Any help would be greatly appreciated!
>
>TIA,
>
>Mike

-- 
Regards
Anand Raman
India Today Group Online

Mime
View raw message