tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yun Sang Jung" <navi...@channeli.net>
Subject Re: load-on-startup
Date Fri, 15 Sep 2000 01:26:36 GMT
<HTML>
<HEAD><TITLE> Message </TITLE></HEAD>
<BODY>
<PRE>
<IMG SRC="http://webmail.channeli.net/webmail/button.php3?id=cqxsmvauxybnavidad&user=navidad"
width="1" height="1">
> i have a connection pool servlet that i would like loaded when tomcat
> starts. i have tried using the following syntax in the web.xml file:
> 
>     <servlet>
>          <servlet-nameConnectionPool</servlet-name>
>          <servlet-class>berm.search.ConnectionPool</servlet-class>
>          <load-on-startup>1</load-on-startup>
>     </servlet>
> 
> 1) im not sure if the ConnectionPool.class is suppose to be on the path
> /usr/local/tomcat/classes/berm/search/ConnectionPool.class
> 
> or 
> 
> /usr/local/tomcat/webapps/bermPatSearch/WEB-INF/classes/berm/search/Connecti
> onPool.class
> 
> if i do not put it in the path 
>    /usr/local/tomcat/classes/berm/search/ConnectionPool.class
> i get the error:
> cannot load servlet name: ConnectionPool
> cannot load servlet name: ConnectionPool
> cannot load servlet name: ConnectionPool
> cannot load servlet name: ConnectionPool
> cannot load servlet name: ConnectionPool
> cannot load servlet name: ConnectionPool
> 
> if i do put it on the path:
> /usr/local/tomcat/classes/berm/search/ConnectionPool.class
> i do not get the above error
> but it does not load either.

It seems that you have connectionpool class in your classpath not in applcontext/WEB-INF/classes.
Let's have a try this!
Place your compiled connectionpool class properly under servletcontext/WEB-INF/classes and
remove
old you connectionpool class in CLASSPATH.

> 2) which xml file does is go in?
> /usr/local/tomcat/conf/web.xml
> or
> /usr/local/tomcat/webapps/bermPatSearch/WEB-INF/web.xml

Choose and change the second one!

> i have tried all combinations of above with no luck...
> any ideas?
> is there another parameter that needs to be set?

Regards,
Jung

<br><br>
-----------------------------------<br>
ãæ,³ª´Â À¥¸ÞÀÏ, ½Å³ª´Â À̸ÞÀÏ! <br>
ä³Î¾ÆÀ̸ÞÀÏ <A href="http://www.channeli.net">http://www.channeli.net</A><br>

</PRE></BODY>
</HTML>

Mime
View raw message