tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "david" <ym...@yahoo.com>
Subject RE: JSPs work but not servlets --- still not working
Date Wed, 13 Sep 2000 18:48:09 GMT
Still not working and going crazy...
There was a typo in my last append, all servlet classes ARE
under webapps/tasp/web-inf/classes are are not in packages (yet).

I have tried with and without a <context> in the server.xml
and with various changes in my /web-inf/web.xml file, but no luck,
JSPs work, but I still get a 404 error for servlets!

I have tried to increase the logging levels in server.xml and for
the context manager, but don't get any helpful output!

Help is much appreciated!!!

thanks 
-- David

------------------------ previous append -------------------------------------------------------------------------------

      Thanks for the help attempts.
      I can get .jsp files to run, but not servlets!!!!  Help!  This Servlet ran fine under
JServe...

      I have my stuff in /webapps/tasp  with the appropriate dir structure
      I have a web.xml file under /webapps/tasp/web-inf:
        <?xml version="1.0" encoding="ISO-8859-1"?>
        <!DOCTYPE web-app
            PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
            "http://java.sun.com/j2ee/dtds/web-app_2.2.dtd">
        <web-app>
             <servlet>
              <servlet-name>ServletTest</servlet-name>
                <servlet-class>ServletTest</servlet-class>
             <servlet-mapping>
                 <servlet-name>ServletTest</servlet-name>
                 <url-pattern>ServletTest</url-pattern>
             </servlet-mapping>
             </servlet>
        </web-app>
      my servlet ServletTest.java and ServletTest.class are under /webapps/tasp/web-inf/classes

      the .jsp that runs is just under /webapps/tasp

      the server.xml has an added context:

              <Context path="/tasp" docBase="webapps/tasp" debug="9" reloadable="true"
> 
              </Context>

      the tomcat.log file is saying:
        Context log: path="/tasp" In error handler 404 null / R( /tasp +  + /ServletTest)
        Context log: path="/tasp" Error: Calling servlet Wrapper(tomcat.errorPage S:org.apache.tomcat.servlets.DefaultErrorPage)
      Any ideas what I'm missing to serve my servlets???  I have tried with "demo" servlets
with no difference...


      Also, am I correct in understanding then that when Tomcat runs alone, it only needss
the server.xml and various web.xml files
      or does it still use the tomcat.properties and zone.properties files????
      Are all the properties files for working with Apache only??

      TIA,
      -- david 

--------------------------------------------------------------------------------


Mime
View raw message