tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "david" <ym...@yahoo.com>
Subject still going nuts trying to get servlets to run (though .jsp run fine)
Date Wed, 13 Sep 2000 17:14:15 GMT
 
Thanks for the help attempts.
I can get .jsp files to run, but not servlets!!!!  Help!  This Servlet ran fine under JServe...

Made a typo in my last append, I DO have the servlets under web-inf/classes and
there are not yet packaged so don't need package qualifiers.

I'm about to throw my computer out the window!
I have all my stuff under webapps so have  tried with and without my context defined in server.xml
I have really tried to mimic the examples closely, as they all run (though I can't figure
out
what the html files are in the exampls/servlets directory...)

I have my stuff in /webapps/tasp  with the appropriate dir structure
I have a web.xml file under /webapps/tasp/web-inf:
  <?xml version="1.0" encoding="ISO-8859-1"?>
  <!DOCTYPE web-app
      PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
      "http://java.sun.com/j2ee/dtds/web-app_2.2.dtd">
  <web-app>
       <servlet>
        <servlet-name>ServletTest</servlet-name>
          <servlet-class>ServletTest</servlet-class>
       <servlet-mapping>
           <servlet-name>ServletTest</servlet-name>
           <url-pattern>ServletTest</url-pattern>
       </servlet-mapping>
       </servlet>
  </web-app>

I have tried with and without the servlet-mapping instruction.
my servlet ServletTest.java and ServletTest.class are under /webapps/tasp/web-inf/classes

the .jsp that runs is just under /webapps/tasp

the server.xml has an added context:

        <Context path="/tasp" docBase="webapps/tasp" debug="9" reloadable="true" > 
        </Context>


Mime
View raw message