tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert V. Sigillito" <rsig...@aplcenMP.apl.jhu.edu>
Subject Startup problems
Date Wed, 09 Aug 2000 00:14:28 GMT
I can't get Tomcat to start. I've defined the JAVA_HOME and CLASSPATH and
I keep getting the following:

[web@test bin]$ ./startup.sh
Guessing TOMCAT_HOME from tomcat.sh to ./..
Setting TOMCAT_HOME to ./..
Using classpath:
.:./../lib/ant.jar:./../lib/jasper.jar:./../lib/servlet.jar:./../lib/test:./../lib/webserver.jar:./../lib/xml.jar:/usr/local/jdk1.2.2/lib/tools.jar:/usr/local/jdk1.2.2/lib/classes.zip:/usr/local/JSDK2.0/lib/jsdk.jar
[webadmin@cybil bin]$ Starting tomcat. Check logs/tomcat.log for error
messages 
FATAL:java.net.BindException: Address already in use
java.net.BindException: Address already in use
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:386)
        at java.net.ServerSocket.<init>(ServerSocket.java:169)
        at java.net.ServerSocket.<init>(ServerSocket.java:120)
        at
org.apache.tomcat.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:97)
        at
org.apache.tomcat.service.SimpleTcpEndpoint.startEndpoint(SimpleTcpEndpoint.java:186)
        at
org.apache.tomcat.service.SimpleTcpConnector.start(SimpleTcpConnector.java:142)
        at
org.apache.tomcat.core.ContextManager.start(ContextManager.java:253)
        at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:157)
        at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)


I've got this on a machine running RedHat 6.0 that I've have Apache
(w/JServ) installed on. I've tried pointing it to port 8888 and 8080, but
I still get this same problem. I think that the problem is something other
than the ports, but I can't seem to find anything in the Jakarta-Tomcat
docs.

Bob


Mime
View raw message