tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "B. Duffee" <b...@cs.keele.ac.uk>
Subject FactoryConfigurationError
Date Mon, 14 Aug 2000 09:26:13 GMT
Hi there:

	I'm having build problems with Tomcat 3.1 under Solaris 2.7 after having 
installed ant, jaxp1.0.1 and xerces 1.1.3 with java1.2.2 and apache1.3.12.  
Running tomcat's build.sh, I get -

BUILD FAILED

javax.xml.parsers.FactoryConfigurationError: 
com.sun.xml.parser.SAXParserFactoryImpl
        at java.lang.Throwable.fillInStackTrace(Native Method)
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Error.<init>(Error.java:41)
        at 
javax.xml.parsers.FactoryConfigurationError.<init>(FactoryConfigurationError.jav
a:68)
        at 
javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:84)
        at org.apache.tools.ant.ProjectHelper.parse(ProjectHelper.java)
        at 
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java)
        at org.apache.tools.ant.Main.runBuild(Compiled Code)
        at org.apache.tools.ant.Main.main(Main.java)

My environment variables are 
CLASSPATH=/usr/java/lib:/usr/jaxp1.0.1/lib:/opt/xerces-1_1_3/class
JAVA_HOME=/usr/java
(it really helped the build process getting the classpath setup correctly)

Can you point me in the right direction?  Thanks,
---
Boyd Duffee			Keele University Comp Sci (01782) 583437 
Computing Officer 		http://www.astro.keele.ac.uk/~bjd/
    <dance> PHP installation is done and dusted! </dance>


Mime
View raw message