tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Morahg, Yoav" <ymor...@gist.com>
Subject building ant
Date Thu, 10 Aug 2000 20:30:42 GMT
Hi.

I previously built tomcat 3.1 on Solaris, but I can't remember how I did it.
I'm trying to rebuild and am trying to follow the instructions for building.
TO begin with, I must have jakarta-ant parallel to my jakarta-tomcat
directory. I got Ant 1.1 from the jakarta site and am now trying to build
it. I executed the bootstrap.sh script successfully but when I try to
execute the build script

(build.sh -Ddist.dir=myant dist) I get the following error:

Exception in thread "main" java.lang.NoClassDefFoundError:
sun/tools/javac/Main
        at org.apache.tools.ant.taskdefs.Javac.doClassicCompile(Compiled
Code)
        at org.apache.tools.ant.taskdefs.Javac.execute(Compiled Code)
        at org.apache.tools.ant.Target.execute(Compiled Code)
        at org.apache.tools.ant.Project.runTarget(Project.java:675)
        at org.apache.tools.ant.Project.executeTarget(Compiled Code)
        at org.apache.tools.ant.Main.runBuild(Compiled Code)
        at org.apache.tools.ant.Main.main(Compiled Code)

my JAVA_HOME is set to /usr/java1.2 and I can't understand where it wants
the sun/tools/javac class from.
I have /usr/java1.2/bin and /usr/java1.2/lib in my PATH.

What am I doing wrong?

Thanks in advance,
-Yoav


---------------------------
Yoav Morahg
Software Engineer
Gist Communications
(212) 965-1999 xt 122
ymorahg@gist.com


Mime
View raw message