tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Chandran" <dchan...@moneynet.com>
Subject Re: IIS not loading isapi_redirect.dll
Date Fri, 11 Aug 2000 18:28:22 GMT


The problem solved, thanks to  Olivier Bethery.  Here is a tip which
should probably go into the tomcat-iis-howto.  Downloading the DLL
directly via Netscape corrupts the file.   Instead, dowload the zip, and
then use the DLL, then IIS 4.0 loads fine.

Thanks,
daniel





"Daniel Chandran" <dchandra@moneynet.com> on 08/10/2000 04:14:59 PM

Please respond to tomcat-user@jakarta.apache.org

To:   tomcat-user@jakarta.apache.org
cc:

Subject:  IIS not loading isapi_redirect.dll





I am running into the problem which has been reported here often -  IIS 4.0 not
loading the isapi_redirect.dll  filter.  I always have the red arrow indicator,
and
the event log has the following error:

The HTTP Filter DLL C:\jakarta-tomcat\bin\iis\i386\bin\isapi_redirect.dll failed
to load.  The data is the error.

My host environment is NT 4.0,  SP5,  IIS 4.0.  I have unistalled and
reinstalled
IIS, SP5, and tried loading the filter with a clean version of IIS. But the woes
continue.    I've followed all the instructions outlined in the iis-howto file,
and
double checked all my registry entries.   Following are my registry settings.

[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation]

[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
Redirector]

[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
Redirector\1.0]
"extension_uri"="/jakarta/isapi_redirect.dll"
"log_file"="C:\jakarta-tomcat\logs\isapi.log"
"log_level"="debug"
"worker_file"="C:\jakarta-tomcat\conf\workers.properties"
"worker_mount_file"="C:\jakarta-tomcat\conf\uriworkermap.properties"

Any help is greatly appreciated.
Thanks,
Daniel G. Chandran
Reuters, Inc.









Mime
View raw message