tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rachel Greenham <rachel.green...@enetgroup.co.uk>
Subject Re: Build Errors - mod_jserv won't build!
Date Thu, 31 Aug 2000 13:39:08 GMT
David Compton wrote:
> 
> I am getting the following error while trying to compile mod_jserv.so.
> 
> I'm using apache 1.3.12 and gcc 2.95.2
> 
>  /usr/local/bin/gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite
>  -DNO_DL_NEEDED -I/usr/local/apache/include -c mod_jserv.c -o
>  autochage.so mod_jserv.so jserv_wrapper_win.so
>  jserv_wrapper_unix.o jserv_wrapper.o jserv_watchdog.o jserv_utils.o
>  jserv_status.o jserv_protocols.o
>  jserv_mmap.o jserv_image.o jserv_balance.o jserv_ajpv12.o jserv_apv11.o
> 
>  autochange.o
>  -o mod_jserv.so
>  apxs:Break: Command failed with rc=16711680
> 
>  Anyone have any idea what this means?

Yes, I know exactly what that is. Had it yesterday.

It means either you don't have an "ld", or the one you have isn't the GNU
ld.

Fix: Either install the gnu binutils, then the apxs command will work fine,
or do the ld command manually something like:

ld -G *.o -o mod_jserv.so

I think.

I did the former in the end. I like the GNU tools, it makes our Solly boxes
much more civilised and Linux-like. :-)

-- 
Rachel


Mime
View raw message