tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Kientzle <kient...@acm.org>
Subject Re: Startup problems
Date Wed, 09 Aug 2000 00:36:34 GMT
Isn't there an FAQ on this?

1) Make sure another copy of Tomcat isn't already running.
  (We've all accidentally tried running two copies of Tomcat before.)

   ps -ef | grep java       (SysV)
   ps -auxww | grep java    (BSD)

2) Use
      netstat -a
   to see which ports are open by other programs.  In the default
   installation, Tomcat tries to open ports 8080 (listens for HTTP
   requests) and 8007 (listens for AJP requests from Apache).
   If another program is using one of those, Tomcat will not start.

   Using additional netstat options in conjunction with fstat,
   it should be possible to track down which program is using those
   other ports, but that's a rather tedious process.

				- Tim


"Robert V. Sigillito" wrote:
> 
> I can't get Tomcat to start. I've defined the JAVA_HOME and CLASSPATH and
> I keep getting the following:
> 
> [web@test bin]$ ./startup.sh
> Guessing TOMCAT_HOME from tomcat.sh to ./..
> Setting TOMCAT_HOME to ./..
> Using classpath:
> .:./../lib/ant.jar:./../lib/jasper.jar:./../lib/servlet.jar:./../lib/test:./../lib/webserver.jar:./../lib/xml.jar:/usr/local/jdk1.2.2/lib/tools.jar:/usr/local/jdk1.2.2/lib/classes.zip:/usr/local/JSDK2.0/lib/jsdk.jar
> [webadmin@cybil bin]$ Starting tomcat. Check logs/tomcat.log for error
> messages
> FATAL:java.net.BindException: Address already in use
> java.net.BindException: Address already in use
>         at java.net.PlainSocketImpl.socketBind(Native Method)
>         at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:386)
>         at java.net.ServerSocket.<init>(ServerSocket.java:169)
>         at java.net.ServerSocket.<init>(ServerSocket.java:120)
>         at
> org.apache.tomcat.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:97)
>         at
> org.apache.tomcat.service.SimpleTcpEndpoint.startEndpoint(SimpleTcpEndpoint.java:186)
>         at
> org.apache.tomcat.service.SimpleTcpConnector.start(SimpleTcpConnector.java:142)
>         at
> org.apache.tomcat.core.ContextManager.start(ContextManager.java:253)
>         at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:157)
>         at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
> 
> I've got this on a machine running RedHat 6.0 that I've have Apache
> (w/JServ) installed on. I've tried pointing it to port 8888 and 8080, but
> I still get this same problem. I think that the problem is something other
> than the ports, but I can't seem to find anything in the Jakarta-Tomcat
> docs.
> 
> Bob

Mime
View raw message