tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Zhan <z...@cyberobject.com>
Subject Re: jk_nt_service error
Date Tue, 08 Aug 2000 15:09:57 GMT
Hi,

Thanks for all respond my questions!

I finally fix it, just change the original line
from
       #wrapper.server_xml=$(wrapper.tomcat_home)\conf\server.xml
to
       wrapper.server_xml=\conf\server.xml

I really don't understand  the reason. The jk_nt_service works after
this change.
Maybe this is a bug of it.
BTW, I set the NT's enviroment variable TOMCAT_HOME=e:\tomcat

Here appends my wrapper.properties file again.

Thanks you  all again.

Fritz Thielemann wrote:

> Hi James,
>
> why you setting the tomcat_home and java_home when you use the absolute path in the
> prop-rows
> like the call of server.xml and java.exe. might be that is the reason why the system
> doubles your path-to.
>
> regards Fritz
>
> James Zhan wrote:
>
> > Hi,
> >
> > Can anybody point me what's wrong with my configuration?
> > I couldn't make jk_nt_service run. The following is the error
> > mesaage
> > ------
> > java.lang.Exception:
> >  Can't open config file: E:\tomcat\e:\tomcat\conf\server.xml
> >  due to: java.io.FileNotFoundException:
> >  E:\tomcat\e:\tomcat\conf\server.xml (The filename, directory name,
> >         or volume label syntax is incorrect)
> >  at org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:214)
> >  at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:110)
> >  at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:130)
> > ----------
> >
> > I don't know why the e:\tomcat doubles in the path. Here is my
> > wrapper.properties
> >
> > Powel Crosley wrote:
> >
> > ? Greetings,
> > ?
> > ? I've got a basic Tomcat setup (v3.1 w/ Apache 3.12) on NT and edited the
> > ? wrapp.properties to reflect my Tomcat Home and Java Home (1.2.2).
> > ?
> > ? When I run jk_nt_service I just get a cryptic message that Tomcat (my
> > ? serviece name) could not start but no message returned.
> > ?
> > ? Can't see anything in the event log.
> > ?
> > ? How do I debug the error?
> > ?
> > ? --
> > ? Regards,
> > ? Powel Crosley
> > ?
> > ? Crosley Consultants
> > ? PO Box 846
> > ? Dunedin
> > ?
> > ? pcrosley@crosley.co.nz
> > ? +64 (03) 477 3596
> > ? +64 (03) 477 3597 Facsimile
> >
> >   ------------------------------------------------------------------------
> >                          Name: wrapper.properties
> >    wrapper.properties    Type: application/x-unknown-content-type-properties_auto_file
> >                      Encoding: base64

Mime
View raw message