tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakob Hummes <hum...@castify.net>
Subject Re: Can't find jars in webapps/WEB-INF/lib
Date Sat, 05 Aug 2000 10:37:22 GMT
Same problem here.  I use also the same workaround (copying the zip for
Oracle under /tomcat/lib).

My config is: Win 2000 (but also tried under Win NT and Linux); Sun JDK
1.2.2 with JIT enabled; Tomcat 3.1 ).

- Jakob

Andrew Jarman wrote:
> 
> Hi,
> 
> This seems like a really stupid question, but I've been fighting it for
> hours:
> 
> I have put together a servlet, along with some required jar files into
> the following dir structure:
> 
> ROOT/WEB-INF/lib/*.jar
> ROOT/WEB-INF/web.xml
> 
> The lib/*.jar includes the servlet classes and some other associated
> classes.  This includes the vbjorb.jar and others so my servlet can
> access an oracle database.
> 
> When I try to load the servlet this way, by servlet starts initializing
> (so I know that the servlet jar file was found), but the init() function
> fails because it can't load all the necessary classes.
> 
> If I copy all of the jar files to the /tomcat/lib directory and restart
> tomcat, everything works fine.
> 
> All of the docs seem to indicate that jar files placed in the
> WEB-INF/lib directory would be added to the CLASSPATH for the
> application.
> 
> What am I doing wrong?
> 
> Assuming somebody helps me figure this out, can I also put .zip files in
> the WEB-INF/lib dir?  (for example, classes12.zip for Oracle)
> 
> Cheers,
> Andrew

Mime
View raw message