tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Lewis <andy.le...@veritas.com>
Subject Re: IBM JDK 1.3 w/ TOMCAT - Help?
Date Wed, 02 Aug 2000 19:24:50 GMT
The SMP discourganment was in the 1.2.2 release notes - at least last time I
looked at them. It works fine though. It was the IBM JDK that I'm having
issues with.

Arun Katkere wrote:

> Where does Sun say this? I know there was "Sun does (sic!) support or
> recommend running the Java 2 SDK on SMP kernels" language in the first beta
> release README, but I remember the beta the July 10 beta refresh
> announcement (which I can't locate right now) specifically mentioned
> addition of SMP support. And the beta refresh README doesn't mention SMP at
> all.
>
> -arun
>
> > -----Original Message-----
> > From: Andy Lewis [mailto:andy.lewis@veritas.com]
> > Sent: Wednesday, August 02, 2000 9:28 AM
> > To: tomcat-user@jakarta.apache.org
> > Subject: Re: IBM JDK 1.3 w/ TOMCAT - Help?
> >
> >
> > Nope. No patch. I've also not found any comments about SMP
> > support for the
> > IBM JDK. Sun specifically indicates that thier JDK is "not
> > recommended" for SMP
> > systems.
> >
> >
> > Ed Yu wrote:
> >
> > > I'm using IBM JDK 1.3 on AIX with both Tomcat and Jserv,
> > that worked like a
> > > charm! Could that be related to the Linux version of JDK
> > 1.3? Try and see if
> > > there is any patch available at
> > http://www.ibm.com/java/jdk/download/.
> > >
> > >
> > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> > > Ed Yu, IBM Certified Specialist - AIX System Administrator
> > > Information Technology Manager,
> > > University of South Carolina,
> > > Advanced Solutions Group, Physics Dept.,
> > > Columbia, SC 29208
> > > Office (803)777-8831, FAX (803)777-8833, Email
> > ekyu@asgnet.psc.sc.edu
> > >
> > > -----Original Message-----
> > > From: Andy Lewis [mailto:andy.lewis@veritas.com]
> > > Sent: Wednesday, August 02, 2000 11:38 AM
> > > To: tomcat-user@jakarta.apache.org
> > > Subject: IBM JDK 1.3 w/ TOMCAT - Help?
> > >
> > > I'm running Tomcat 3.1 on Radhat 6.1 with Apache 1.3.12 and have had
> > > some major problems with the IBM 1.3 JDK. Sadly, I've had
> > to go back to
> > > the Sun 1.2.2.  The two symptoms were that the Tomcat
> > shutdown didn't
> > > work right - basically the Java processes would stick
> > around, holding
> > > the port, but not responsind to and connection requests for about 3
> > > minutes before actually going away. Most of them would go
> > away before
> > > that with a simple "kill", but two of them would require a
> > "kill -9" to
> > > remove. The second symptom was that Tomcat would simply
> > hang and stop
> > > serving requests after 6 or 7 hours. Neither case produced any error
> > > messages of relevant log entries. Tomcat is running as a
> > "tomcat" user.
> > > The system is a Dual PIII 550.
> > >
> > > Perhaps something related to the dual processors with the IBM JDK?
> > >
> > > Has anyone else seen anything like this?
> > >
> > > Not time critical - I'm up and running fine on Sun 1.2.2,
> > but it does
> > > bug me....
> > >
> > > Thanks!
> >


Mime
View raw message