tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David M. Holmes" <david_m_hol...@yahoo.com>
Subject Re: fatal error on startup
Date Tue, 08 Aug 2000 22:10:44 GMT
Linux or NT? Please include your server.xml source. Its possible that an old instance of Tomcat
is
still running, look for java.exe process...

--- KTJ Music <atjeu@ktjmusic.com> wrote:
> ok, i see it trying to respond on 8080 for web requests and 8443 for
> org.apache.tomcat.service.http.HttpConnectionHandler
> and those are the only 2 that I see in there.
> 8080 is being used by apache but 8443 doest show up when I do a nestat -a
> and I still get the following error when trying to start tomcat:
> FATAL:java.net.BindException: Address already in use
> java.net.BindException: Address already in use
>         at java.net.PlainSocketImpl.socketBind(Native Method)
>         at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:414)
>         at java.net.ServerSocket.<init>(ServerSocket.java:182)
>         at java.net.ServerSocket.<init>(ServerSocket.java:132)
>         at
> org.apache.tomcat.net.DefaultServerSocketFactory.createSocket(Default
> ServerSocketFactory.java:97)
>         at
> org.apache.tomcat.service.PoolTcpEndpoint.startEndpoint(PoolTcpEndpoi
> nt.java:235)
>         at
> org.apache.tomcat.service.PoolTcpConnector.start(PoolTcpConnector.jav
> a:187)
>         at
> org.apache.tomcat.core.ContextManager.start(ContextManager.java:450)
>         at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:204)
>         at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:237)
> 
> Any ideas there?
> 
> 
> 
> 
> 
> ----- Original Message -----
> From: "David M. Holmes" <david_m_holmes@yahoo.com>
> To: <tomcat-user@jakarta.apache.org>; "KTJ Music" <atjeu@ktjmusic.com>
> Sent: Tuesday, August 08, 2000 2:07 PM
> Subject: Re: fatal error on startup
> 
> 
> > server.xml is where the ports are set for standalone web and ajp...
> >
> > --- KTJ Music <atjeu@ktjmusic.com> wrote:
> > > the only thing I see there is port 8007 which doesnt show up when I do
> > > netstat -a , I am new to this stuff so bear with me - is there any
> specific
> > > config file I should be looking at?
> > > ----- Original Message -----
> > > From: "Tom Orsi" <torsi@zingaretti.com>
> > > To: <tomcat-user@jakarta.apache.org>
> > > Sent: Tuesday, August 08, 2000 1:57 PM
> > > Subject: Re: fatal error on startup
> > >
> > >
> > > > config files?
> > > >
> > >
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Kick off your party with Yahoo! Invites.
> > http://invites.yahoo.com/
> >
> 


__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

Mime
View raw message