tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shaun Campbell <Shaun.Campb...@entranet.co.uk>
Subject Tomcat configuration
Date Wed, 23 Aug 2000 10:49:01 GMT
First of all, I have Jyve running successfully.

I am now trying to set up a new context underneath the webapps directory.  I
have inserted the following line in tomcat.conf:

	ApJServMount /sample /root  

underneath the 
	ApJServMount /examples /root	
line.

I have also added the following lines to server.xml

        <Context path="/sample" docBase="webapps/sample" debug="0"
reloadable="t
rue" >
        </Context>    

I have restarted Tomcat and now I get the following error when I run Jyve:

Exception: java.lang.NullPointerException: 
	at org.apache.jyve.screens.MainMenu.doBuild(MainMenu.java:94)
	at org.apache.turbine.modules.Screen.build(Screen.java:88)
	at
org.apache.turbine.modules.ScreenLoader.eval(ScreenLoader.java:117)
	at
org.apache.jyve.layouts.DefaultLayout.doBuild(DefaultLayout.java:92)
	at org.apache.turbine.modules.Layout.build(Layout.java:81)
	at
org.apache.turbine.modules.LayoutLoader.exec(LayoutLoader.java:111)
	at
org.apache.turbine.modules.pages.DefaultPage.doBuild(DefaultPage.java:134)
	at org.apache.turbine.modules.Page.build(Page.java:81)
	at org.apache.turbine.modules.PageLoader.exec(PageLoader.java:111)
	at Turbine.doGet(Turbine.java:298)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java:503)
	at
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java:597)
	at
org.apache.tomcat.servlets.InvokerServlet.service(InvokerServlet.java:257)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java:503)
	at
org.apache.tomcat.core.ContextManager.service(ContextManager.java:559)
	at
org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection
(Ajp12ConnectionHandler.java:156)
	at
org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java:338
)
	at java.lang.Thread.run(Thread.java:475)

Any ideas what I am doing wrong?

Thanks

Shaun Campbell

Mime
View raw message