tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elizabeth hampton" <hampt...@mediaone.net>
Subject Re: Help!!
Date Fri, 11 Aug 2000 00:38:47 GMT
Thanks for the advice Marcel, I have set up my classpath as follows:

¦set cp=%CLASSPATH%
¦
¦set CLASSPATH=.
¦set CLASSPATH=%TOMCAT_HOME%\classes
¦set CLASSPATH=%CLASSPATH%;%JAVA_HOME%
¦set CLASSPATH=%CLASSPATH%;%JAVA_HOME%\lib
¦set CLASSPATH=%CLASSPATH%;%JAVA_HOME%\lib\tools.jar
¦set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\webserver.jar
¦set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\jasper.jar
¦set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\xml.jar
¦set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\servlet.jar

I now get two new error messages, Out of environment space (while running my tomcat.bat script)
and the output of a tomcat run looks like this:

Out of environment space
Using classpath: C:\Program_Files\jakarta-tomcat\classes;C:\Program_Files\jdk1.3;C:\Program_Files\jdk1.3\lib
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/startup/Tomcat

It looks like I run out of environment space when the script is setting the classpath and
therefore, java is having a hard time finding the .jar files.  I'm going to hunt the internet
for advice on configuring my dos window to have more environment space (maybe this is a problem
with how memory is being allocated?)

If anyone knows offhand, please e-mail me.

Thank you in advance.

  ----- Original Message ----- 
  From: Marcel Landman 
  To: tomcat-user@jakarta.apache.org 
  Sent: Thursday, August 10, 2000 2:54 AM
  Subject: Re: Help!!


  You need to set your CLASSPATH also to the directory of 
  you java because it cannnot find some major jar-files..... 
  Marcel Landman 
  DIC Information Consultants 
    

  Elizabeth hampton wrote: 

    I'm trying to get tomcat to run as part of the directions for installing cocoon. System:
windows 95Java2 SDK standard edition 1.3 (for windows)stable (so I thought) binaries for tomcat
 upon execution of a tomcat start (or tomcat run) I get the following errors: Using classpath:
C:\Program_Files\jakarta-tomcat\classes;C:\Program_Files\jakart 
    a-tomcat\lib\webserver.jar  
    Exception in thread "main" java.lang.NoClassDefFoundError: org/xml/sax/DocumentH 
    andler  
            at java.lang.ClassLoader.defineClass0(Native Method) 
            at java.lang.ClassLoader.defineClass(Unknown Source) 
            at java.security.SecureClassLoader.defineClass(Unknown Source) 
            at java.net.URLClassLoader.defineClass(Unknown Source) 
            at java.net.URLClassLoader.access$100(Unknown Source) 
            at java.net.URLClassLoader$1.run(Unknown Source) 
            at java.security.AccessController.doPrivileged(Native Method) 
            at java.net.URLClassLoader.findClass(Unknown Source) 
            at java.lang.ClassLoader.loadClass(Unknown Source) 
            at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) 
            at java.lang.ClassLoader.loadClass(Unknown Source) 
            at java.lang.ClassLoader.loadClassInternal(Unknown Source) 
            at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:134) 
            at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163) Does anyone have any
solutions?  I tried to create a subdirectory called classes underneath jakarta-tomcat since
I didn't see this directory after I did the initial install.  I've also tried copying the
tools.jar file into my classpath as well as making additional copies of the .jar files in
the /lib subdirectory and placing them in /classes.  None of these gimmicks worked. Any suggestions?

Mime
View raw message