tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Janet" <ja...@chinasystems-cn.com>
Subject why there is always "403 forbidden" error after I tried to use Tomcat with Apache?
Date Wed, 16 Aug 2000 07:02:50 GMT
Hello!

I'm quite new to Apache and Tomcat.  I installed Redhat6.2 so I have
Apache1.3.12 on my machine. I downloaded Tomcat3.1. Until then both of them
(Tomcat ran as standalone) worked well. I mean, when I typed
http://localhost/ or http://localhost:8080/ into the browser it showed the
page properly.

And the next day I tried to use Tomcat as an add-on to Apache. So I followed
the steps:
1. add "include /usr/local/Tomcat/conf/tomcat.conf" at the end of file
"httpd.conf".
2. change the corresponding line in file "tomcat.conf" to:
   "LoadModule jserv_module /usr/lib/apache/mod_jserv.so"
(I've copied mod_jserv.so to that directory already.)
3.start Tomcat.
4. restart Apache.

Now when I tried to access the webserver, there is the 403 error!

I checked Apache's error_log file. There are statements as:
 "client denied by server configuration: /home/httpd/html"

I checked the access rights of the /home/httpd/ and its subdirectories. it
allows anyone to read/execute. And I restart the httpd as root.

I checked the httpd.conf, access.conf and srm.conf. I couldn't find a
statement that obviously has something to do with the access restriction.

But as I said I know little about Apache and Tomcat. Would anyone kindly
point out the possible solution to the problem?

Many many thanks!

Best regards:
Janet




Mime
View raw message