tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinay Nath" <vinaynat...@hotmail.com>
Subject Please Help - Tomcat Stopped working after being used for a week
Date Wed, 26 Jul 2000 07:21:49 GMT
Hi all,

I am getting a very strange problem.I installed tomcat a week ago and used
it to run my servlets and JSP's.I even made my own contexts.
But from yesterday tomcat is not working on my computer.
I haven't changed any path in fact i was not using tomcat for the past two
days.
Getting fedup of all this i removed tomcat from my system and reinstalled
it.
Still i m getting the same error.
I am using win95.I also tried to run it on NT4.0 but it gave the same error.
I don't know wht has happened to my system.
The error that i m getting is :

C:\jakarta\tomcat\bin>tomcat run
Using classpath:
C:\jakarta\tomcat\classes;C:\jakarta\tomcat\lib\webserver.jar;C
:\jakarta\tomcat\lib\jasper.jar;C:\jakarta\tomcat\lib\xml.jar;C:\jakarta\tom
cat\
lib\servlet.jar;C:\JDK1.2.1\lib\tools.jar;.;c:\jdk1.2.1\jre\lib\rt.jar;c:\jd
k1.2
1\jre\lib\jaws.jar;c:\jdk1.2.1\jre\lib\i18n.jar;C:\JDK1.2.1\LIB\TOOLS.JAR;C
:\JD
K1.2.1\LIB\jdbc2_0-stdext.JAR;c:\jakarta\tomcat\lib\webserver.jar;c:\jakarta
\tom
cat\lib\servlet.jar;c:\jakarta\tomcat\lib\ant.jar;c:\jakarta\tomcat\lib\jasp
er.j
ar;c:\jakarta\tomcat\lib\xml.jar;c:\jswdk-1.0.1\webserver.jar;c:\jswdk-1.0.1
\lib
\servlet.jar;c:\jswdk-1.0.1\lib\jspengine.jar;c:\jswdk-1.0.1\lib\xml.jar
java.lang.ClassNotFoundException:
org/apache/tomcat/service/http/HttpConnectionH
andler
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Compiled Code)
        at
org.apache.tomcat.service.SimpleTcpConnector.setProperty(SimpleTcpCon
nector.java:180)
        at java.lang.reflect.Method.invoke(Native Method)
        at org.apache.tomcat.util.xml.MethodSetter.end(Compiled Code)
        at org.apache.tomcat.util.xml.XmlMapper.matchEnd(Compiled Code)
        at
org.apache.tomcat.util.xml.XmlMapper.endElement(XmlMapper.java:96)
        at com.sun.xml.parser.Parser.maybeElement(Compiled Code)
        at com.sun.xml.parser.Parser.content(Compiled Code)
        at com.sun.xml.parser.Parser.maybeElement(Compiled Code)
        at com.sun.xml.parser.Parser.content(Compiled Code)
        at com.sun.xml.parser.Parser.maybeElement(Compiled Code)
        at com.sun.xml.parser.Parser.content(Compiled Code)
        at com.sun.xml.parser.Parser.maybeElement(Compiled Code)
        at com.sun.xml.parser.Parser.parseInternal(Compiled Code)
        at com.sun.xml.parser.Parser.parse(Parser.java:283)
        at org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:198)
        at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:143)
        at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
Context log: path="/examples" Adding context path="/examples"
docBase="webapps/
examples"
Starting tomcat. Check logs/tomcat.log for error messages Context log:
path="" A
dding context path=""  docBase="webapps/ROOT"

Context log: path="/test" Adding context path="/test"
docBase="webapps/test"
FATAL:java.lang.Exception: Invalid ConnectionHandler
java.lang.Exception: Invalid ConnectionHandler
        at
org.apache.tomcat.service.SimpleTcpConnector.start(SimpleTcpConnector
java:133)
        at org.apache.tomcat.core.ContextManager.start(Compiled Code)
        at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:157)
        at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\jakarta\tomcat\bin>

The PATH and CLASSPATH are :

SET
PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;C:\DOS;C:\JDK1.2.1\BIN;c:\jswdk-1.0.1;C:\
jsdk2.0\bin;C:\KAWA321;d:\tasm\bin

SET
CLASSPATH=.;c:\jdk1.2.1\jre\lib\rt.jar;c:\jdk1.2.1\jre\lib\jaws.jar;c:\jdk1.
2.1\jre\lib\i18n.jar;C:\JDK1.2.1\LIB\TOOLS.JAR;C:\JDK1.2.1\LIB\jdbc2_0-stdex
t.JAR;c:\jakarta\tomcat\lib\webserver.jar;c:\jakarta\tomcat\lib\servlet.jar;
c:\jakarta\tomcat\lib\ant.jar;c:\jakarta\tomcat\lib\jasper.jar;c:\jakarta\to
mcat\lib\xml.jar;c:\jswdk-1.0.1\webserver.jar;c:\jswdk-1.0.1\lib\servlet.jar
;c:\jswdk-1.0.1\lib\jspengine.jar;c:\jswdk-1.0.1\lib\xml.jar

The TOMCAT_HOME and JAVA_HOME are :

SET TOMCAT_HOME=C:\jakarta\tomcat

SET JAVA_HOME=C:\JDK1.2.1

Please help as i need to use this software very urgently.

Thanks in advance...

Vinay
IEC Softwares Ltd.
Delhi


Mime
View raw message