tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Koontz (MapQuest)" <dkoo...@mapquest.com>
Subject tomcat 3.1 w/ NT myapp example problems
Date Thu, 20 Jul 2000 19:51:31 GMT
I've just downloaded Tomcat 3.1 installed on Win NT as standalone.

I've tried to build the tomcat\doc\appdev\sample\ project.

It has several problems some I've figured out - but I'm still stumped
(had no problems on Linux - but this aint Linux)

1) the build.bat would give:
D:\tomcat\doc\appdev\sample>build
D:\tomcat\lib\jasper.jar was unexpected at this time.

seams to be an issue with the %CLASSPATH%

D:\tomcat\lib\servlet.jar;D:\tomcat\lib\jasper.jar;E:\Java;E:\MQES1.5.1\lib\
MapQ
uestX.jar;E:\MQES1.5.1\lib\MQJavaCore-0.96.jar;.;E:\oracle\LITE\CLASSES\OLIT
E35.
JAR

rem'ed out the echo off in build.bat gives more ensight:

D:\tomcat\doc\appdev\sample>build

D:\tomcat\doc\appdev\sample>rem@echo off
The name specified is not recognized as an
internal or external command, operable program or batch file.

D:\tomcat\doc\appdev\sample>rem build.bat -- Build Script for the "Hello,
World"
 Application

D:\tomcat\doc\appdev\sample>rem $Id: build.bat,v 1.1 2000/04/04 22:01:13
craigmc
c Exp $
D:\tomcat\doc\appdev\sample>if
D:\tomcat\lib\servlet.jar;D:\tomcat\lib\jasper.ja
r;E:\Java;E:\MQES1.5.1\lib\MapQuestX.jar;E:\MQES1.5.1\lib\MQJavaCore-0.96.ja
r;.;
E:\oracle\LITE\CLASSES\OLITE35.JAR == "" goto noclasspath
D:\tomcat\lib\jasper.jar was unexpected at this time.

It appears the problem is that the %CLASSPATH% doesn't have quotes around
it - it should???

so fixing that - taking out the rem on the @echo off

I now get:

D:\tomcat\doc\appdev\sample>build
Buildfile: build.xml
BUILD CONFIG ERROR: Can't open config file: build.xml due to:
org.xml.sax.SAXPar
seException: Attribute names must not start with "<" characters.
org.apache.tools.ant.BuildException: Can't open config file: build.xml due
to: o
rg.xml.sax.SAXParseException: Attribute names must not start with "<"
characters
.
        at
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.jav
a:93)
        at org.apache.tools.ant.Main.runBuild(Main.java:223)
        at org.apache.tools.ant.Main.main(Main.java:191)

looking at the build.xml file the line:
  <property name="app.name"       value="myapp"
doesn't have a "/>" like all the rest - so lets fix this.

now we get these errors:

D:\tomcat\doc\appdev\sample>build
Buildfile: build.xml
Project base dir set to: D:\tomcat\doc\appdev\sample
The items attribute is deprecated. Please use the includes attribute.
The items attribute is deprecated. Please use the includes attribute.
Executing Target: prepare
BUILD FATAL ERROR: srcdir does not exist!

<rant>
WHAT THE HELL IS GOING ON HERE
</rant>

OK - I'll guess the key word "items" can be replaced with "includes" - try
it...

appears to work - but still get the
BUILD FATAL ERROR: srcdir does not exist!

This is where I lose it... the src dir does exist in the current dir
(\tomcat\doc\appdev\sample\src)

Help please
David


Mime
View raw message