tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Shevland" <>
Subject RE: Include not passing parameters?
Date Wed, 26 Jul 2000 01:55:56 GMT
Doh! Worked perfectly, thankyou. In my first attempt at using <jsp:include...> I specified
'false' for the flush parameter as I thought this might flush the outer buffer out (and subsequently
caused it to throw a 500 Server Error I think). After reading this section of the spec again
it is clear to me know.

Thanks again.


>-----Original Message-----
>From: Christopher Go []
>Sent: Wednesday, 26 July 2000 11:34 AM
>Subject: Re: Include not passing parameters?
>You should send the param as a separate line.
><jsp:include page="inc_stage.jsp" flush="true">
>    <jsp:param name="stage" value="1" />
>Hope this works.
>----- Original Message -----
>From: "Joe Shevland" <>
>To: "List, Tomcat User" <>
>Sent: Tuesday, July 25, 2000 6:00 PM
>Subject: Include not passing parameters?
>I'm using the @include directive (Apache 1.3.12/SSL/Tomcat 3.1) to include
>another JSP file in an index page I'm using:
><%@ include file="inc_stage.jsp?stage=1" %>
>so I can increment a stage counter from page to page.
>If I view 'inc_stage.jsp?stage=1' directly in my browser 
>everything is fine,
>however when the above tag is embedded in another JSP that is called, the
>parameter 'stage' is not getting passed through. This (I believe) worked
>under JServ, can anyone see anything I'm doing wrong? I tried
><jsp:include...> but that won't get translated which is what I'm after.

View raw message