tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "klaus spd" <klaus...@hotmail.com>
Subject Re: problem with IIS and tomcat on win2k
Date Sat, 15 Jul 2000 12:16:54 GMT
>Did you reboot your server???

yes. i tried rebooting as well. although i believe "net stop iisadmin" 
should be enough to kill all IIS stuff.
but thanks anyway for your quick response!

>If you followed all the steps in the how-to for NT and IIS and after you
>have changed the uriworkermap.*,
>it seems you have to reboot to get it working. I had the same problem,
>thought there would be something wrong in the uriworkermap.
>I always restarted the IIS in the MMC, but that isn't just enough. There
>must be a better way to completely restart IIS but for me only a reboot
>helped. (Perhaps this should go into the how-to???)
>
>Greetings
>Till
>
>Caught in our narrowminded believe...
>######################################################
>
>Till Woerner
>Berlin, Germany
>
>######################################################
>
>----- Original Message -----
>From: klaus spd <klausspd@hotmail.com>
>To: <tomcat-user@jakarta.apache.org>
>Sent: Saturday, July 15, 2000 11:18 AM
>Subject: problem with IIS and tomcat on win2k
>
>
> > i tried to get tomcat (3.1 and 3.2b2) working with IIS5.0 on win2k with
>it's
> > "isapi_redirect.dll" + Ajp12ConnectionHandler, but all i get (with IE5.0
>or
> > NS3.0) is: "HTTP 404".
> >
> > the isapi filter is working (i can see the green arrow up in the mmc) 
>and
> > the log file shows this entry:
> > ...
> > [jk_uri_worker_map.c (214)]: Into
>jk_uri_worker_map_t::uri_worker_map_open,
> > match rule /admin/servlet/=ajp12 was added
> > [jk_uri_worker_map.c (203)]: Into
>jk_uri_worker_map_t::uri_worker_map_open,
> > suffix rule /admin/.jsp=ajp12 was added
> > [jk_uri_worker_map.c (214)]: Into
>jk_uri_worker_map_t::uri_worker_map_open,
> > match rule /admin/=ajp12 was added
> > ...
> > [jk_worker.c (98)]: Into wc_open
> > [jk_worker.c (217)]: Into build_worker_map, creating 1 workers
> > [jk_worker.c (223)]: build_worker_map, creating worker ajp12
> > [jk_worker.c (154)]: Into wc_create_worker
> > [jk_worker.c (168)]: wc_create_worker, about to create instance ajp12 of
> > ajp12
> > [jk_ajp12_worker.c (264)]: Into ajp12_worker_factory
> > [jk_worker.c (177)]: wc_create_worker, about to validate and init ajp12
> > [jk_ajp12_worker.c (182)]: Into jk_worker_t::validate
> > [jk_ajp12_worker.c (194)]: In jk_worker_t::validate for worker ajp12
>contact
> > is localhost:8007
> > [jk_worker.c (187)]: wc_create_worker, done
> > [jk_worker.c (233)]: build_worker_map, removing old ajp12 worker
> > [jk_worker.c (245)]: build_worker_map, done
> > [jk_worker.c (118)]: wc_open, done
> > ...
> >
> > and for my request on "http://127.0.0.1/admin/index.html" the log shows:
> > ...
> > [jk_isapi_plugin.c (385)]: In HttpFilterProc test redirection of
> > /admin/index.html
> > [jk_uri_worker_map.c (286)]: Into jk_uri_worker_map_t::map_uri_to_worker
> > [jk_uri_worker_map.c (338)]: jk_uri_worker_map_t::uri_worker_map_open,
>done
> > with ajp12
> > [jk_isapi_plugin.c (395)]: In HttpFilterProc /admin/index.html should
> > redirect to ajp12
> > ...
> >
> >
> > the tomcat log tells me:
> > ...
> > "2000-07-15 11:05:35 - PoolTcpConnector: Starting Ajp12ConnectionHandler
>on
> > 8007"
> > ...
> > this handler is listening( i used telnet on localhost:8007 and got an
> > exception in tomcat's log file). but nothing for my normal request. i 
>have
> > got another HttpConnectionHandler listenting on 8080 and this one works
>just
> > fine.
> >
> > my friend tried idependently about the same configuration on his machine
>but
> > with no success either.
> > now i am really desperate because i need this installation to finish my
> > theses(university).
> > does anyone have an idea?
> >
> > thanks,
> >
> > klaus
> >
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com


Mime
View raw message