tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Propp <gary.w.pr...@syntegra.com>
Subject Re: compiling libjserv.so
Date Wed, 19 Jul 2000 20:02:43 GMT
Look at apxs. There is a shell variable that has no value. This is the variable
that is just before the -o parameter. I fixed it at home,
but do not have access to apxs at work. I think I set the variable to something
like gcc -install??? Good luck.

"Hand, Brian C." wrote:

> All,
>
> I am having some difficulty on compiling libjserv.so on solaris 2.6
>
> Here is the command and error messages.
>
> # apxs -c *.c -o mod_jserv.so
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c autochange.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_ajpv11.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_ajpv12.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_balance.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_image.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_mmap.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_protocols.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_status.cgcc -DSOLARIS2=260 -DUSE_EXPAT
> -I../lib/expat-lite -DNO_DL_NEEDED  -I/usr/local/apache/include  -c
> jserv_utils.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_watchdog.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_wrapper.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_wrapper_unix.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c jserv_wrapper_win.c
> gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
> -I/usr/local/apache/include  -c mod_jserv.c
>   -o autochange.so mod_jserv.o jserv_wrapper_win.o jserv_wrapper_unix.o
> jserv_wrapper.o jserv_watchdog.o jserv_utils.o jserv_status.o
> jserv_protocols.o jserv_mmap.o jserv_image.o jserv_balance.o jserv_ajpv12.o
> jserv_ajpv11.o autochange.o -o mod_jserv.so
> apxs:Break: Command failed with rc=16711680
> #
>
> What gives?  Please Help!!!!!
>
> Thanks
> Brian


Mime
View raw message