tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurizio Calcara <m.calc...@cgsgroup.it>
Subject Re: HANDLER THREAD PROBLEM
Date Mon, 03 Jul 2000 10:23:22 GMT
Unfortunately I try to talk *only* with the server (by using
ajpv12://localhost) but Netscape seems  to try to use the http protocol
to locate the server and it says   again:  "Netscape is unable to locate
the server ajpv12:.".
Is there any setting has to be made into the "http.conf" file (apart the
"include tomcat-apache.conf") .
Thanks.

Ed wrote:

> You should not be trying to directly communicate to the 8007 port at
> all.  Stop it.  You talk to the web-server then *it* talks to the 8007
> port.  It is supposed to be transaparent.
>
>      ----- Original Message -----
>      From:Maurizio Calcara
>      To: tomcat-user@jakarta.apache.org
>      Sent: Monday, July 03, 2000 10:32 AM
>      Subject: Re: HANDLER THREAD PROBLEM
>       Hi Rob,
>      thank's for your help.
>      Unfortunately I'm trying to use ajpv12as communication
>      protocol (ajpv12://localhost:8007), but Netscape says
>      "Netscape is unable to locate the server ajpv12:.".
>      Are there other configurations that have to be made on the
>      server ??
>
>      Thank you again,
>          Maurizio
>
>      "Rob S." wrote:
>
>     > 'allo,We did the same thing when we were installing Tomcat
>     > =) The protocol used to communicate with Tomcat on port
>     > 8007 is ajpv12.  You're trying to use HTTP.  By default,
>     > that port is meant for webserver-Tomcat communication.Hope
>     > it helps!- r
>     >
>     >      -----Original Message-----
>     >      From: maurizio@cgsgroup.it
>     >      [mailto:maurizio@cgsgroup.it]On Behalf Of
>     >      Maurizio Calcara
>     >      Sent: June 30, 2000 9:14 AM
>     >      To: tomcat-user@jakarta.apache.org
>     >      Subject: HANDLER THREAD PROBLEM
>     >      Hi,
>     >      I'm installing  "Tomcat  3.1" on a Linux RedHat
>     >      6.1  system running  a  2.2.15  kernel and the
>     >      "jdk1.2.2" Java version.
>     >      By using Tomcat in stand-alone mode it works
>     >      fine.
>     >
>     >      When I try to use Tomcat with Apache (both 1.3.9
>     >      and 1.3.12) by means the "mod_jserv.so" (I try
>     >      to connect to "http://localhost:8007",  the
>     >      default settings) the console produces the
>     >      following error:
>     >
>     >           HANDLER THREAD PROBLEM:
>     >           java.io.IOException: Stream
>     >           brokenjava.io.IOException: Stream
>     >           broken
>     >            at
>     >           org.apache.tomcat.service.connector.AJP12RequestAdapter.readNextRequest(Ajp12ConnectionHandler.java:386)
>     >
>     >            at
>     >           org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection(Ajp12ConnectionHandler.java:134)
>     >
>     >            at
>     >           org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java:338)
>     >
>     >            at
>     >           java.lang.Thread.run(Thread.java:475)
>     >
>     >
>     >      Please,  Is there anybody that solved this
>     >      problem???
>     >      Any idea??
>     >      Thanks,
>     >          Maurizio Calcara
>     >
>     >      --
>     >
>     >      dr. Maurizio Calcara
>     >      m.calcara@cgsgroup.it
>     >
>     >
>     >
>      --
>
>      dr. Maurizio Calcara
>      m.calcara@cgsgroup.it
>
>
>
--

dr. Maurizio Calcara
IT Manager - CGS sas
 via S.Cecilia, 16
56124 - Pisa (Italy)
Fax: +39 050 573854
Tel: +39 050 573205
m.calcara@cgsgroup.it



Mime
View raw message