tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dudley Irish <dir...@arsmagna.com>
Subject Error with JDBC connecting from servlet
Date Sat, 15 Jul 2000 16:44:52 GMT
Hello all,

I am new to Tomcat and, in fact, am only involved as sysadmin and DBA
so I don't even know Java that well and, to top it all off, I am
having a very strange problem.

The root error is that the JDBC driver reports that the network device
cannot connect.  (I would report the text of the error, but I can't
get to the machine from here.)

Here is what makes the problem strange.  This is the test box that I
have just set up.  The development box works.  The same application or
so the developers assure me.  More over, the database works fine.  Any
way that we can think of to connect to the database, works.  The
sample app that comes with the database (Oracle8i R2) works.  It can
connect to the database using the same JDBC drivers that the
application is using.  And now the really wierd fact, when we redirect
the application to use the development instance of the database rather
than the test instance, it works.  I am really stumped.

So this is basically a fishing expedition.  I have run out of things
to check.  Today, I am going to try and find the critical
configuration difference between the two systems, but I don't even
know where to look.  If I don't have any luck, I will at least be in a
position to give a detailed description of the configuration.  They
are supposed to both be running Redhat 6.1, the latest Apache rpm for
6.1, the latest stable jakarta-tomcat, jdk-1.2.2, the latest JDBC
thin drivers from Oracle, and Oracle8iR2.

If you have any ideas as to what might be the issue; anything that I
can check, please email.

Mime
View raw message