tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Wasner <t...@wrq.com>
Subject Correct mod_server.so? -> Need help getting Tomcat and Apache t o co-operate
Date Mon, 17 Jul 2000 23:21:01 GMT
Hi,

I am trying to get Tomcat to cooperate with my Apache Web Server on Caldera
Linux. First, let me say that running Tomcat alone at http://localhost:8080
works fine.

My Apache version is as follows:
Server version: Apache 1.3.9 (Unix)
Server Built: Nov 19, 1999 01:11:28

The problem with getting Tomcat to work with Apache appears to be getting a
version of the MOD_JSERV.SO that my Apache install will recognize. I've
downloaded the binaries including the MOD_JSERV.SO for Linux from the
Jakarta Project download site.

I've modified the TOMCAT.CONF file so with the following line:

LoadModule jserv_module /usr/libexec/apache/mod_jserv.so

I can start Tomcat ok but when I try to start the Apache server using the
httpd command, it simply will not start. All I get is the prompt back. ps -A
| grep httpd gets nothing. 

If I rem out the above LoadModule line in tomcat.conf, then Apache will
start ok.

With the binary version of Tomcat, I tried the mod_jserv.so version off of
the download site. I also downloaded the source code and  built a version of
the mod_serv.so by myself using the information in the User's Guide - apxs
-c *.c -o mod_jserv.so but I got the same results - Apache just won't start.

I then downloaded the Tomcat 3.2 beta version and with the downloaded
version of mod_jserv.so, received the following error message:

Syntax Error on line 13 of /tomcat32/jakarta-tomcat/conf/tomcat.conf API
module structure  'jserv_module' in file /usr/libexec/apache/mod_jserv.so is
garbled - perhaps this is not an Apache  module DSO?

So at least some sort of error handling is working but ...

Again, I tried building a 3.2 beta version of the mod_jserv.so using the
apxs command but the Apache server will just not start.

I've read the listserver archives to glean out tips and have found a lot of
posts about people having problems with the version of the mod_jserv.so.
These range from warnings when downloading with Netscape to special apxs
build parameters. I've doublechecked and tried most everything so any and
all help is appreciated.

thanks in advance,
tomw
tomw@wrq.com

Mime
View raw message