tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicola Ken Barozzi" <nicola...@supereva.it>
Subject Tomcat 3.1 JVM exiting frequently - mine too!
Date Mon, 10 Jul 2000 19:38:51 GMT

----- Original Message ----- 
From: <gtaylor@pgac.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Monday, July 10, 2000 4:44 PM
Subject: Tomcat 3.1 JVM exiting frequently


> 
> 
> Hey, guys - hope you can help with my problem here.  I'm running Tomcat 3.1
> standalone with default pooled connector settings on NT 4.0 SP6 with Sun JDK
> 1.3.  The problem is that the process just completely exits about once a day
> (obviously not good.)  There's nothing negative in any of the logs.  I'm only
> running two servlets with very low traffic (currently in testing.)
> 
> I'm trying to figure out what's causing it to dump.  It seems like sometimes it
> stops even when the server is not being hit.
> 
> Question:  If the servlet code generates an unchecked exception (NullPointer,
> whatever) will it bring down the whole environment or does the servlet engine
> them?  If it DOES cause an exit, I don't suppose there's any way to make Tomcat
> log it before it dumps?  I wrote an NT service wrapper for Tomcat (though I now
> hear one already existed somewhere) and I could go back and make it capture
> STDERR/STDOUT to files, but we're trying to roll this into production this week
> and I'm trying not to use the extra time.
> 
> Sorry that's not much to go on.  I've been running Tomcat 3.1 on an AS/400 in
> JDK 1.2 for weeks at a time with no problems, so I don't get this one.  Thanks
> in advance for anyone who can help...
> 

Mine shuts down every hour!
I'm using W2K, Sun 1.22 and HotSpot 1.

Ken


Mime
View raw message