tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Huri <h...@huri.net>
Subject Problems with Tomcat 3.1
Date Tue, 13 Jun 2000 16:51:50 GMT
When I was compiling Tomcat 3.1 I received an error about a class not
being found in the last file it was compiling.

org.apache.tomcat.core.HttpServletRequestFacade
was looking for
org.apache.tomcat.core.RequestUtil

which of course didn't exist.

The only way I was able to make it compile was to manually go into
HttpServletRequestFacade and add 
import org.apache.tomcat.util.RequestUtil;

even though
import org.apache.tomcat.util.*;
was already in there... but it finally compiled...

So I got Tomcat up and running, tried out a couple different
configurations, got all of my servlets from 3.0 added to 3.1 and then when
I tried to access the servlets I got this message:

java.lang.NoClassDefFoundError: org/apache/tomcat/core/RequestUtil
at org.apache.tomcat.core.RequestImpl.getCookies(RequestImpl.java:379)
at org.apache.tomcat.request.SessionInterceptor.requestMap(SessionInterceptor.java:101)
at org.apache.tomcat.core.ContextManager.processRequest(ContextManager.java:594)
at org.apache.tomcat.core.ContextManager.service(ContextManager.java:552)
at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:160)
at org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java:338)
at java.lang.Thread.run(Thread.java:498)

Which is telling me that it's still looking for that class in the wrong
directory! What is going on?

Here's the details.

Base OS: Linux Slackware 7.0
HTTP Server: Apache 1.3.9
JDK: IBM Java SDK 1.3

The only thing that I can think of that has changed since I compiled 3.0
is the JDK as I had Blackdown JDK 1.2 (also a beta) at the time.
Tomcat 3.0 is running great, even under the new VM, don't know what could
be the problem other than perhaps the compiler... any ideas?

Huri



Mime
View raw message