tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bolton, Ian H" <ian.bol...@eds.com>
Subject RE: Authentication Problem
Date Fri, 02 Jun 2000 09:46:21 GMT
Nacho,

I tried the nightly build of 3.2 dev for 1st June (I downloaded the
binaries).

This works OK although the latest build seems to require the JAXP (Java XML
extension) from Sun's site :-)

In the security example supplied with Tomcat, the getRemoteUser call now
works fine, which is good enough for what I need.  

There still seems a problem in the getUserPrincipal call (unless I have
misunderstood the way it works).  After starting up Tomcat, and accessing
the protected area for the first time, getUserPrincipal returns the correct
user name.  However getPrincipal seems to continue to return that user name,
even if you log on later as another user.

Ian

-----Original Message-----
From: Nacho [mailto:nacho@siapi.es]
Sent: 01 June 2000 14:16
To: 'tomcat-user@jakarta.apache.org'
Subject: RE: Authentication Problem


Hi, Ian 

This a known bug in tomcat 3.1 final ( i suppouse that this i what you
are using ), the lastest nightly build security should work without
problems.......

Saludos ,
Ignacio J. Ortega

> -----Mensaje original-----
> De: Bolton, Ian H [mailto:ian.bolton@eds.com]
> Enviado el: jueves 1 de junio de 2000 14:34
> Para: 'tomcat-user@jakarta.apache.org'
> Asunto: Authentication Problem
> 
> 
> I am struggling to run the "out of the box" Basic authentication 
> example with Tomcat 3.1...

Mime
View raw message