tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Eyara <iey...@k2000.com>
Subject Building problem
Date Tue, 13 Jun 2000 08:36:13 GMT
I'm using tomcat 3.1 + jdk 1.2.2 on a Red Hat 6.1

Tomcat is running perfectly: both servlets and jsp's examples are ok.
Now, I'm trying to develop a simple servlet and when I try to compile it
I get an error.

This is the build.sh script I'm using:

#! /bin/bash
#build -- Build Script for "Direcciones Web"

# Variables
TOMCAT_HOME=/usr/local/jakarta-tomcat

# Identify the custom class path components we need
CP=$TOMCAT_HOME/classes:$TOMCAT_HOME/lib/ant.jar:$TOMCAT_HOME/lib/xml.jar
CP=$CP:$TOMCAT_HOME/lib/jasper.jar:$TOMCAT_HOME/lib/servlet.jar
CP=$CP:$TOMCAT_HOME/lib/webserver.jar
    
# Execute ANT to perform the requested build target
java -Dtomcat.home=$TOMCAT_HOME -classpath $CP:$CLASSPATH
org.apache.tools.ant.Main "$@"

And this is the error message I get when I run it:

[ivan@lisa direcciones_web]$ ./build.sh compile
Buildfile: build.xml
Project base dir set to: /home/ivan/src/direcciones_web
Executing Target: prepare
Executing Target: compile
Compiling 1 source files to
/usr/local/jakarta-tomcat/webapps/direcciones_web/WEB-INF/classes
Exception in thread "main" java.lang.NoClassDefFoundError:
sun/tools/javac/Main
	at org.apache.tools.ant.taskdefs.Javac.doClassicCompile(Javac.java:418)
	at org.apache.tools.ant.taskdefs.Javac.execute(Javac.java:218)
	at org.apache.tools.ant.Target.execute(Target.java:120)
	at org.apache.tools.ant.Project.runTarget(Project.java:675)
	at org.apache.tools.ant.Project.executeTarget(Project.java:422)
	at org.apache.tools.ant.Main.runBuild(Main.java:240)
	at org.apache.tools.ant.Main.main(Main.java:191)

Thanks in advance,
--
Ivan

Mime
View raw message