tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anke Steuernagel <a...@opus5.de>
Subject Re: Tomcat using port 0 -- tomcat.log
Date Wed, 14 Jun 2000 07:20:39 GMT
On Tue, Jun 13, 2000 at 01:01:35PM +0200, Volker Turau wrote:
> 
> >>it seems that in your file server.xml there is a section
> 
> >>      <Connector className="org.apache.tomcat.service.SimpleTcpConnector">
> >>          <Parameter name="handler" value="org.apache.tomcat.service.http.HttpConnectionHandler"/>
> >>          <Parameter name="port" value="0"/>
> >>      </Connector>
> 
> No you are wrong! This is my sever.xml (part of it)
> 
>     <Connector className="org.apache.tomcat.service.SimpleTcpConnector">
>             <Parameter name="handler" value="org.apache.tomcat.service.connector.Ajp12ConnectionHandler"/>
>             <Parameter name="port" value="8007"/>
>     </Connector>
> 
> May be it is because I have no HttpConnectionHandler at all, there must be
> something hidden?

Hmmm, I don't know of any default HttpConnectionHandler. I thought that
only those parts are started which are configured within server.xml.

Please show us your whole server.xml.
How do you start the tomcat server(s), automatically or manually? 
You can start it manually by calling
	/tomcat.sh start -f <your_server.xml>

bye, anke

-- 
[ a n k e   s t e u e r n a g e l ]
        diplom-informatikerin (fh)   http://www.opus5.de
        opus 5  interaktive medien gmbh   frankfurter stra├če 151c
        63303 dreieich   fon: +49 6103 5853-146   fax: -200

Mime
View raw message