tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksandr Shneyderman" <a...@law.columbia.edu>
Subject Re: extreme newbie can't install ant...
Date Fri, 30 Jun 2000 13:52:19 GMT
I remeber seeing istallation notes requested tools.jar in your classpath.
Put it in and try again.

Alex.

----- Original Message -----
From: <tomcat-user@jakarta.apache.org>
To: <tomcat-user@jakarta.apache.org>
Sent: Friday, June 30, 2000 11:16 AM
Subject: extreme newbie can't install ant...


Hi,

I'm a little desparate to get this going today if possible, I've
mailed for the FAQs but there are none.  There is only an
Ant developer list and this is more a user/install question, and
presumably everyone has compiled ant to get tomcat working
(except me...)

I'm using RedHat Linux 6.2

I have jdk1.2.2 installed with

CLASSPATH = /usr/local/jdk1.2.2/lib
JAVA_HOME = /usr/local/jdk1.2.2
PATH=/usr/local/jdk1.2.2/bin

as jdk1.2.2 is insrtalled in /usr/local/jdk1.2.2

I downloaded jakarta-ant from the jakarta.apache.org web page...

I ran the bootstrap.sh .. it failed at first because java_home or
classpath
wasn't defined, not sure which, I did both at the same time.. then
the bootstrap.sh script worked.  Then I tried to install the
distributiion with

./build.sh -Ddist.dir=/usr/local/ant

Executing Target: check_for_optional_packages
Executing Target: compile
Compiling 53 source files to /usr/local/src/jakarta-ant/build/classes
Exception in thread "main" java.lang.NoClassDefFoundError:
sun/tools/javac/Main
        at
org.apache.tools.ant.taskdefs.Javac.doClassicCompile(Javac.java:418)
        at org.apache.tools.ant.taskdefs.Javac.execute(Javac.java:218)
        at org.apache.tools.ant.Target.execute(Target.java:120)
        at org.apache.tools.ant.Project.runTarget(Project.java:675)
        at org.apache.tools.ant.Project.executeTarget(Project.java:422)
        at org.apache.tools.ant.Main.runBuild(Main.java:240)
        at org.apache.tools.ant.Main.main(Main.java:191)


Can anyone tell me what I've done wrong?  Can I use (or should I)
be using a newer JDK? if so which one.. the docs and readme seemed
to only say 1.2, but may have been old I guess.

Thanks

Bill



--------------------------------------------------------------------------
To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
For additional commmands, email: tomcat-user-help@jakarta.apache.org




Mime
View raw message