tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xander Heemskerk" <xheem...@factotum.nl>
Subject Re: Tomcat Load Balancing
Date Tue, 27 Jun 2000 07:35:55 GMT
Gad,

I see you don't have a shared memory file defined:
ApJServShmFile logs/jserv_shm 
And you do not have a zone defined
ApJServMount /servlet balance://set1/zone1.

Also you have used the default port 8007 on both machines. It could be your using the default
port on machine in stead of the load balancing port.
Try using another port than 8007 and check the mod_jserv.log if you are using the load balancing.
Good luck Xander
  ----- Original Message ----- 
  From: Gad B 
  To: 'tomcat-user@jakarta.apache.org' 
  Cc: Gal Shachor 
  Sent: Tuesday, June 27, 2000 12:24 AM
  Subject: Tomcat Load Balancing


  Hi All,
  I am struggling with Load Balancing and Tomcat 3.1. I got Tomcat on 2 machines and a configuration
file
  for Apache JServ to balance requests between the two.
   
  ############# from tomcat.conf (included in httpd.conf) ###############
  ApJServMount /servlet balance://spark1/servlet 
    
  ApJServBalance spark1 PC1 
  ApJServBalance spark1 PC2 

  ApJServHost PC1 ajpv12://mymachine1:8007 
  ApJServHost PC2 ajpv12://mymachine2:8007 

  ApJServRoute JS1 PC1 
  ApJServRoute JS2 PC2 

  ############# from tomcat.conf (included in httpd.conf) ###############
   
  From the documentation I gather that this is all I need to define. I started tomcat on both
machines
  and apache is running on mymachine1.
  My problem is that everything works only with mymachine1. mymachine2 never gets any requests.

   
  Is there anyone on the list who has done load-balancing with Tomcat 3.1? If so, I would
appreciate 
  any advice on the subject.
   
  Thanks,
  Gad


Mime
View raw message