tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Weiss" <Swe...@aamc.org>
Subject RE: JSP engine fails when trying to compile java / Apache / Tomcat / Unix
Date Wed, 24 May 2000 22:42:23 GMT
Are you using the correct mod_jserv?  You should be using the one from the Jakarta site, not
the one from JServ itself.

Stephen A. Weiss       Association of American Medical Colleges
(202)828-0428       mailto:sweiss@aamc.org   http://www.aamc.org

>>> nmarriage@ingenta.com 05/24/00 08:52AM >>>
Thanks, Steve, for your advice. Most kind.

I did what you suggested and it falls over in a different way now!
Now when I try to go to one of the example jsp pages in my browser, I get:

1. Blank screen on the browser and it hangs, apparently, for ever.

2. The following message on the Unix terminal from which I started tomcat:

HANDLER THREAD PROBLEM: java.io.IOException: Stream broken
java.io.IOException: Stream broken
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Exception.<init>(Compiled Code)
        at java.io.IOException.<init>(Compiled Code)
        at org.apache.tomcat.service.connector.AJP12RequestAdapter.readNextRequest(Compiled
Code)
        at org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection(Compiled
Code)
        at org.apache.tomcat.service.TcpConnectionThread.run(Compiled Code)
        at java.lang.Thread.run(Compiled Code)

3. The following in jasper.log:

<JASPER_LOG> Wed May 24 12:24:59 GMT+01:00 2000 Parent class loader is: org.apache.tomcat.loader.AdaptiveServletLoader@1da653e7</JASPER_LOG>

<JASPER_LOG> Wed May 24 12:24:59 GMT+01:00 2000 Scratch dir for the JSP engine is: /opt/local/jakarta-tomcat/work/localhost_8080%2fexamples</JASPER_LOG>

<JASPER_LOG> Wed May 24 12:24:59 GMT+01:00 2000 IMPORTANT: Do not modify the generated
servlets</JASPER_LOG> 
<JASPER_LOG> Wed May 24 12:25:00 GMT+01:00 2000 Parent class loader is: org.apache.tomcat.loader.AdaptiveServletLoader@1da646c6</JASPER_LOG>

<JASPER_LOG> Wed May 24 12:25:01 GMT+01:00 2000 Parent class loader is: org.apache.tomcat.loader.AdaptiveServletLoader@1da63dd0</JASPER_LOG>

<JASPER_LOG> Wed May 24 12:25:02 GMT+01:00 2000 Parent class loader is: org.apache.tomcat.loader.AdaptiveServletLoader@1da651db</JASPER_LOG>


4. The following in servlet.log

Context log path="/examples" :tomcat.errorPage: init
Context log path="/examples" :default: init
Context log path="/examples" :jsp: init
Context log path="/test" :tomcat.errorPage: init
Context log path="/test" :default: init
Context log path="/test" :jsp: init
Context log path="/admin" :tomcat.errorPage: init
Context log path="/admin" :default: init
Context log path="/admin" :jsp: init
Context log path="" :tomcat.errorPage: init
Context log path="" :default: init
Context log path="" :jsp: init

5. The following in tomcat.log

Starting endpoint port="8008" handler="org.apache.tomcat.service.connector.Ajp12ConnectionHandler"


Note, I am not using the usual port (8007) for the AJP12 connection, deliberately.


Can Steve or anyone else out there help me please? This is still driving me round the bend!

Thanks again in advance,
Nick Marriage, ingenta.com, Bath, UK

>-----Original Message-----
>From: steve@bath.ac.uk [mailto:steve@bath.ac.uk]On Behalf Of Steve Weiss
>Sent: Tuesday, May 23, 2000 18:04
>To: tomcat-user@jakarta.apache.org 
>Subject: Re: JSP engine fails when trying to compile java / Apache /
>Tomcat / Unix
>
>
>Nick Marriage wrote:
>> 
>
>> I have installed tomcat and apache, as per the Minimalistic User 
>Guide for Tomcat. I've started 
>> Another odd thing, which might have something to do with it, is 
>that in the jasper.log
>> files which tomcat creates, it says (amongst other things):
>> 
>> <JASPER_LOG> Tue May 23 13:13:28 GMT+01:00 2000 Classpath 
>according to the Servlet Engine is: 
>/opt/local/jakarta-tomcat/webapps/examples/WEB-INF/classes</JASPER_LOG>
>> 
>> What happened to the rest of my classpath, which, when I started 
>Tomcat via tomcat.sh is announced to be:
>>  
>.:./../lib/ant.jar:./../lib/jasper.jar:./../lib/servlet.jar:./../li
>b/test:./../lib/webserver.jar:./../lib/xml.jar:/usr/java1.2/jre/lib
>:/usr/java1.2/bin:/tools/external/xml/xml4j_2_0_11/xml4j/xml4j.jar:
>/tools/external/jserv_1.0/JSDK2.0/lib/jsdk.jar
>> 
>> Has anyone out there got any tips as to what I've done wrong? 
>This has been driving me round the bend for days now!
>> 
>
>It looks like you need to add <path-to-jdk>/lib/tools.jar to your
>classpath before you start Tomcat. (or classes.zip if you're using
>jdk1.1). That would also account for your missing Hashtable problem ;)
>
>-- 
>Steve Weiss      Association of American Medical Colleges
>(202)828-0428    mailto:sweiss@aamc.org    http://www.aamc.org 
>
>--------------------------------------------------------------------------
>To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org 
>For additional commmands, email: tomcat-user-help@jakarta.apache.org 
>
>


--------------------------------------------------------------------------
To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org 
For additional commmands, email: tomcat-user-help@jakarta.apache.org 


Mime
View raw message