tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From emount...@amadeus.net
Subject Re: JDK 1.3: Ant not producing .class files
Date Wed, 10 May 2000 14:36:18 GMT
Add
    <property name="build.compiler" value="classic"/>
to your build.xml project.

Ant assumes modern compile with JDK 1.3, the modern compile method does nothing
currently, so you have to force "classic".

Cheers,
:E




From: "Michael P. McCutcheon" <michaelm@value.net>  on 10/05/2000 01:28 PM GMT

Please respond to tomcat-user@jakarta.apache.org
                                                                                
                                                                                
                                                                                


|--------->
|         |
|--------->
  >--------------------------------------------------------------------------->
  |                                                                           |
  >--------------------------------------------------------------------------->
  >-------------------------------------------|
  |                                           |
  >-------------------------------------------|
|--------->
|To:      |
|--------->
  >--------------------------------------------------------------------------->
  |tomcat-user@jakarta.apache.org                                             |
  >--------------------------------------------------------------------------->
  >-------------------------------------------|
  |                                           |
  |                                           |
  >-------------------------------------------|
|--------->
|cc:      |
|--------->
  >--------------------------------------------------------------------------->
  | (bcc: Eric Mountain/NCE/AMADEUS)                                          |
  >--------------------------------------------------------------------------->
  >-------------------------------------------|
  |                                           |
  |                                           |
  >-------------------------------------------|
|--------->
|         |
|--------->
  >--------------------------------------------------------------------------->
  |                                                                           |
  >--------------------------------------------------------------------------->
  >-------------------------------------------|
  |                                           |
  >-------------------------------------------|
|--------->
|Subject: |
|--------->
  >--------------------------------------------------------------------------->
  |JDK 1.3: Ant not producing .class files                                    |
  >--------------------------------------------------------------------------->
  >-------------------------------------------|
  |                                           |
  >-------------------------------------------|







I have some build.xml files that I have been using with JDK 1.2.2 on
Win2000.  When I switched to the new JDK 1.3, ant still runs my build.xml
file, and the output says that all is well.  However, it won't generate any
.class files.  It does not produce any errors when it gets to the compile
phase, but it goes through it almost instantly, like it isn't actually
compiling.

Anyone know what this could be?

Are there any known problems with the JDK 1.3 and Ant?

Mike



--------------------------------------------------------------------------
To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
For additional commmands, email: tomcat-user-help@jakarta.apache.org





Mime
View raw message