tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. William McCarthy" <jayb...@mail.com>
Subject Web Applications and Contexts
Date Sun, 28 May 2000 17:52:36 GMT
I've successfully incorporated a Tomcat 1.3 install into my existing
Apache 1.3.12 installation.  I'm able to see the examples, they all work
okay, yada yada yada....

My problem arises when I try to either:

1. Add servlets to existing contexts.  I tried sticking a servlet I know
works into /home/tomcat/webapps/ROOT/WEB-INF/classes where the
"SnoopServlet" that come with the package is.  I can get a SnoopServlet
but not at my own.  I get a 404 from Tomcat.  (Not Apache)  I tried
restarting both Apache and Tomcat.  Niether worked.

2. Add new contexts.  I must be dumb.  I read the docs, followed the
examples, etc, and I simply can't seem to get a new context working.  I
copied the "examples" line in server.xml and added all the info for my
app and restarted.  I can get to the static content in the
webapps/mynewapp directory, but I can't get at the servlets in
webapps/mynewapp/WEB-INF/classes

Any ideas?  I thought it might have to do with the web.xml file, but I
looked at other web.xml files (ROOT and examples seem to have nothing
but placeholder tags in them)


Mime
View raw message