tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinny <vi...@blendermania.com>
Subject newbie q: helloworld servlet
Date Sun, 28 May 2000 17:13:14 GMT
Okay, I recompiled the standard the sample HelloWorldExample.java
servlet. It complied without error. 
I then moved it to another directory and it will not execute.
This works: http://localhost/examples/servlet/HelloWorldExample
and http://localhost:8080/examples/servlet/HelloWorldExample
these does not:
 http://localhost/myserver/servlet/HelloWorldExample
 http://localhost:8080/myserver/servlet/HelloWorldExample

I was under the impression that anything with a /servlet/*
would be sent to the invoker to be executed. I'm probably 
missing something very obvious. Does something have to be 
done to the classfile after compiling?

Near  the end of the server.xml I have

        <!-- example - how to override AutoSetup actions -->
        <Context path="/examples" docBase="webapps/examples" debug="0" reloadable="true"
> 
        </Context>
        <!-- example - how to override AutoSetup actions -->
        <Context path="" docBase="webapps/ROOT" debug="0" reloadable="true" > 
        </Context>

        <Context path="/test" docBase="webapps/test" debug="0" reloadable="true" > 
        </Context>


        <Context path="/myserver" docBase="webapps/myserver" debug="0" reloadable="true"
> 
        </Context>



and I basically copied the same diretory stucture that webapps/examples has

When I compile and place a exampple servlet in webapps/examples/WEB-INF/classes I can execute
it with http://localhost/examples/servlet/ExampleServlet
but doing the same with  webapps/myserver/WEB-INF/classes does not produce a corresponding

result.

Thanks
-- 
Vincent Stoessel-vinny@blendermania.com
Xaymaca Studios http://www.blendermania.com

Mime
View raw message