tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: myapp question
Date Wed, 24 May 2000 18:07:51 GMT
Jacob Kjome wrote:

> That's the strange thing.  I had everything compiled.  I changed nothing but
> the the class name:  changed it from Hello.class to HelloWorld.class and
> changed the web.xml file to look for the HelloWorld class rather than Hello
>
> That was it.  I've got that directory structure down just fine.  Actually, I
> am running Tomcat through Apache Web Server 1.3.12 using the ApacheJServ...
> thingy.
>
> I have 3 separate webapps going other than the examples and test that come
> with the server.
>
> The weird thing is, I tried this at home and it worked.
>
> I brought the entire Jakarta dir + all subdirs and files and used that here
> at work.  myapp at home ran fine, but not at work until I changed the
> Hello.class to HelloWorld.class
>
> I even tried to put the Hello.class in other webapps that I had working
> fine.  Didn't work there either until I put the HelloWorld.class there.
>
> I know this is kind of bizarre.  Given all the webapps that I have working,
> I think I've proven I know a little about what I'm doing.  I'm just
> wondering if anyone has a rational reason for this to happen.  Does my
> theory that I stated in the earlier message hold water?
>
> BTW, I do shutdown and restart both the web server and Tomcat (always
> starting Tomcat and then the web server) any time I make any sort of change.
>
> Any other ideas?
>
> Jake
>

Yah, that is definitely bizarre.

Could you do me a favor?  Zip up the entire "myapp" directory when it does not
work right, and send it to me in private EMAIL.  I'd like to take a look and see
what's going on.

Craig McClanahan



Mime
View raw message