tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritesh Kumar <rite...@blr.aptech.ac.in>
Subject Re: Changes in Servlet not getting loaded
Date Thu, 11 May 2000 14:00:29 GMT
Hi,

But I have cleared all cache of browser and then closed it and then restarted
browser. Even then this happens

-Ritesh

BCR \\ CRAPART Bruno wrote:

> In my opinion, it is a cache problem.
> This lines might help you.
>
> <META HTTP-EQUIV="Pragma" CONTENT="no-cache">
> <META HTTP-EQUIV="Cache-Control" CONTENT="no-cache">
> <%
>   response.setHeader("Expires", "Mon, 26 Jul 1990 05:00:00 GMT");
> // Date in the past
>   response.setHeader("Cache-Control" ,"no-cache, must-revalidate");
> // HTTP/1.1
>   response.setHeader("Pragma", "no-cache");
> // HTTP/1.0
> %>
>
> -----Message d'origine-----
> De : Ritesh Kumar [mailto:riteshk@blr.aptech.ac.in]
> Envoyé : jeudi 11 mai 2000 15:40
> À : tomcat-user@jakarta.apache.org
> Objet : Changes in Servlet not getting loaded
>
> Hi,
>
> When I put a fresh servlet under /webapps/example/WEB-INF/classes it
> works fine.
>
> But if I change .java file and compile to .class file and then try to
> use that servlet then also it picks up old .class file and not the
> updated one.
>
> Only when I restart tomcat and then apache, the new .class file is
> uploaded.
>
> Anyidea why this happens?
>
> Thanks & Regards,
> Ritesh Kumar.
>
> --------------------------------------------------------------------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org

Mime
View raw message