tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: JSDK 2.1 development --> JSDK 2.2 in Tomcat
Date Wed, 10 May 2000 22:12:51 GMT
"Dunkle, Ed" wrote:

> Is it critical to compile code against the same JSDK version that is in
> Tomcat?
>
> I am developing in an environment that uses JSDK 2.1 but then deploy to
> Tomcat 3.1 which includes JSDK 2.2.  My JSPs don't work under Tomcat
> although they work fine in development.
>

The differences in the servlet API between 2.1 and 2.2 were almost all
additions, so it's pretty much upward compatible.

>
> I guess the other difference is that I am presently using JSP .9 spec in
> developemnt.  That won't fly in Tomcat, right?  I have to use JSP 1.1 spec?
>

That's right -- the tag syntax under JSP 1.0/1.1 is very much different from the
syntax of JSP 0.91 or 0.92.  These pages are not going to be compatible at all.

> Ed
>

Craig McClanahan


>
> --------------------------------------------------------------------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org


Mime
View raw message