tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Ruby <st...@rubysolutions.com>
Subject servlet project build error (starting with doc/webapp/sample/)
Date Tue, 09 May 2000 19:44:51 GMT

I have tried tomcat from:
20000509 servletapi binary + 20000509 tomcat binary
(recent Ant binaries are 0k I assume they are included in
the tomcat release now).

tomcat is fine, examples are fine but when I try to build
the sameple project in appdev I get

------------------
Project base dir set to:
/usr/local/src/java/servlets/jakarta/fromsource/build/tomcat/doc/appdev/sample

BUILD CONFIG ERROR

build.xml:21: Unexpected attribute "init"
------------------
I remove all occurences of init assuming maybe it got depreciated
or something then I get
build.xml:28: srcdir does not exist!


So I tried
20000509 sources (ant+servletapi+tomcat)
all compiled fine (save some -depreciated errors when running
./build.sh dist in the jakarta-tomcat distribution) tomcat server
works fine but again a problem trying to make the sample project

------------------
Buildfile: build.xml
Project base dir set to: /home/rubyjn/GardenersGuide
The items attribute is deprecated. Please use the includes attribute.
The items attribute is deprecated. Please use the includes attribute.
Executing Target: prepare
BUILD FATAL ERROR: srcdir does not exist!
------------------


I tried also the 3.1 binary release and again all worked fine but
there appears to be corruption in the archive, the build script
in the sample directory has an extra invisible character at the top, I
can
fix this file but then I get an error on build something about
(cannot use "<" in the name of a property.) The build.xml file
looks clean, I can't find any extra "<" character

I took the build.xml and build script from my source build and
I get the same error regarding srcdir

this is all on current stable linux (based on redhat dist).


This seems to be an ant problem but there is no ant user list.
The general@jakarta... list is not active.

I've been working on this with nightly builds from previous nights 
with the same results. the only entry about this I find in the archive
the responder said to use a newer version of ant.....


Thanks for any help.

I've been runnning JServ for a long time without problem I'm working
on upgrading to the new-way, but I can't build a project with the
.war type structure without build/build.xml working ..

jaxp 1.0.1 from java.sun.com/xml is in the CLASSPATH on all attempts
indicated above.

I'm using jdk 1.2.2 from sun

Mime
View raw message