tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eyal golan <e...@itginc.com>
Subject Tomcat3.1 - Apache intergation problem
Date Wed, 03 May 2000 23:53:20 GMT
Hello,

I was using the Tomcat beta version until recently.
Now I'm trying to use the 3.1 version and I
can't get it to work with Apache (the beta version worked and still
working fine).



Was there any change in how the either Apache or Tomcat have to be
configured for 3.1?


More specifically, here is what I have:

in tomact.conf :

    ApJServMount /examples   /my_app/v1


in server.xml:


       <Context path="/my_app/v1" docBase="webapps/my_app/v1" debug="0"
reloadable="true">
       </Context>


(the tomcat-apache.conf contains:

Alias
/my_app/v1/home/Intranet/jakarta/jakarta-tomcat_3.1/webapps/my_app/v1
<Directory
"/home/Intranet/jakarta/jakarta-tomcat_3.1/webapps/my_app/v1">
    Options Indexes FollowSymLinks
</Directory>
ApJServMount /my_app/v1/servlet /my_app/v1
<Location /my_app/v1/WEB-INF/ >
    AllowOverride None
    deny from all
</Location>

under <jakarta-tomact>/webapps i have the following directories:

my_app/v1/WEB-INF/  (contains the web.xml file)
my_app/v1/images/
my_app/v1/servlet/ (contains all the .class files)
my_app/v1/servlets/  (the html files)


in the httpd.conf i have:

Include /home/Intranet/jakarta/jakarta-tomcat/conf/tomcat-apache.conf



Then I run Tomcat and Apache (yes, in that order)

in the servlet.log I get the following messages:

Context log path="/admin" :tomcat.errorPage: init
Context log path="/admin" :jsp: init
Context log path="/admin" :default: init
Context log path="/examples" :tomcat.errorPage: init
Context log path="/examples" :jsp: init
Context log path="/examples" :default: init
Context log path="/wong" :tomcat.errorPage: init
Context log path="/wong" :jsp: init
Context log path="/wong" :default: init

Context log path="/my_app" :tomcat.errorPage: init
Context log path="/my_app" :jsp: init
Context log path="/my_app" :default: init

Context log path="/test" :tomcat.errorPage: init
Context log path="/test" :jsp: init
Context log path="/test" :default: init

Context log path="/my_app/v1" :tomcat.errorPage: init
Context log path="/my_app/v1" :jsp: init
Context log path="/my_app/v1" :default: init

Context log path="" :tomcat.errorPage: init
Context log path="" :jsp: init
Context log path="" :default: init



and when I type in the browser the following url:
"http://<server>/my_app/v1"

the static html  frames are loaded but the servlet hangs forever (the
index.html is actually a frameset)




AND, if I switch back to the 3.0 beta version - everything works!!!!



Any ideas?


thanks a lot,

Eyal Golan
ITG Inc.


Mime
View raw message