tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Marriage <nmarri...@ingenta.com>
Subject JSP engine fails when trying to compile java / Apache / Tomcat / Unix
Date Tue, 23 May 2000 15:15:21 GMT

I have installed tomcat and apache, as per the Minimalistic User Guide for Tomcat. I've started
tomcat and apache, apparently successfully. Apache seems to work for html files ok. When I
try to use it with any of the jsp examples provided, I get, in my browser, instead of the
jsp application I asked for, the following message:

Error: 500
Location: /examples/jsp/num/numguess.jsp
Internal Servlet Error:

org.apache.jasper.JasperException: Unable to compile class for JSP
	at java.lang.Throwable.(Compiled Code)
	at java.lang.Exception.(Compiled Code)
	at javax.servlet.ServletException.(Compiled Code)
	at org.apache.jasper.JasperException.(Compiled Code)
	at org.apache.jasper.runtime.JspServlet.loadJSP(Compiled Code)
	at org.apache.jasper.runtime.JspServlet$JspServletWrapper.loadIfNecessary(Compiled Code)
	at org.apache.jasper.runtime.JspServlet$JspServletWrapper.service(Compiled Code)
	at org.apache.jasper.runtime.JspServlet.serviceJspFile(Compiled Code)
	at org.apache.jasper.runtime.JspServlet.service(Compiled Code)
	at javax.servlet.http.HttpServlet.service(Compiled Code)
	at org.apache.tomcat.core.ServletWrapper.handleRequest(Compiled Code)
	at org.apache.tomcat.core.ContextManager.service(Compiled Code)
	at org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection(Compiled
Code)
	at org.apache.tomcat.service.TcpConnectionThread.run(Compiled Code)
	at java.lang.Thread.run(Compiled Code)

Root cause: 
java.lang.IllegalArgumentException: Unknown argument
	at java.lang.Throwable.(Compiled Code)
	at java.lang.Exception.(Compiled Code)
	at java.lang.RuntimeException.(Compiled Code)
	at java.lang.IllegalArgumentException.(Compiled Code)
	at java.text.MessageFormat.format(Compiled Code)
	at java.text.MessageFormat.format(Compiled Code)
	at java.text.Format.format(Compiled Code)
	at org.apache.jasper.Constants.getString(Compiled Code)
	at org.apache.jasper.Constants.message(Compiled Code)
	at org.apache.jasper.compiler.JspParseEventListener.handleDirective(Compiled Code)
	at org.apache.jasper.compiler.DelegatingListener.handleDirective(Compiled Code)
	at org.apache.jasper.compiler.Parser$Directive.accept(Compiled Code)
	at org.apache.jasper.compiler.Parser.parse(Compiled Code)
	at org.apache.jasper.compiler.Parser.parse(Compiled Code)
	at org.apache.jasper.compiler.Parser.parse(Compiled Code)
	at org.apache.jasper.compiler.Compiler.compile(Compiled Code)
	at org.apache.jasper.runtime.JspServlet.loadJSP(Compiled Code)
	at org.apache.jasper.runtime.JspServlet$JspServletWrapper.loadIfNecessary(Compiled Code)
	at org.apache.jasper.runtime.JspServlet$JspServletWrapper.service(Compiled Code)
	at org.apache.jasper.runtime.JspServlet.serviceJspFile(Compiled Code)
	at org.apache.jasper.runtime.JspServlet.service(Compiled Code)
	at javax.servlet.http.HttpServlet.service(Compiled Code)
	at org.apache.tomcat.core.ServletWrapper.handleRequest(Compiled Code)
	at org.apache.tomcat.core.ContextManager.service(Compiled Code)
	at org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection(Compiled
Code)
	at org.apache.tomcat.service.TcpConnectionThread.run(Compiled Code)
	at java.lang.Thread.run(Compiled Code)

I also, mysteriously, get the message

  Unknown object of type:java.util.Hashtable

which appears at the Unix command line prompt from which I previously started Tomcat.

Another odd thing, which might have something to do with it, is that in the jasper.log
files which tomcat creates, it says (amongst other things):

<JASPER_LOG> Tue May 23 13:13:28 GMT+01:00 2000 Classpath according to the Servlet Engine
is: /opt/local/jakarta-tomcat/webapps/examples/WEB-INF/classes</JASPER_LOG> 

What happened to the rest of my classpath, which, when I started Tomcat via tomcat.sh is announced
to be:
 .:./../lib/ant.jar:./../lib/jasper.jar:./../lib/servlet.jar:./../lib/test:./../lib/webserver.jar:./../lib/xml.jar:/usr/java1.2/jre/lib:/usr/java1.2/bin:/tools/external/xml/xml4j_2_0_11/xml4j/xml4j.jar:/tools/external/jserv_1.0/JSDK2.0/lib/jsdk.jar

Has anyone out there got any tips as to what I've done wrong? This has been driving me round
the bend for days now!

Thanks in advance
Nick Marriage


Mime
View raw message