tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Goodman" <tom_good...@bigfoot.com>
Subject Re: Can't debug JSP in VisualAge
Date Tue, 23 May 2000 02:21:03 GMT
Gads!

Now when I try JSP compilation in Windows (with the eval version of
VisualAge and tomcat 3.1), the compiler dies during the compilation of that
page and shows the following in the browser:


Error: 500
Location: /examples/jsp/dates/date.jsp
Internal Servlet Error:

org.apache.jasper.JasperException: Unable to compile class for JSPerror:
File .\_classes\javax\servlet\ServletException.class does not contain type
ServletException as expected, but type javax.servlet.ServletException.
Please remove the file, or make sure it appears in the correct subdirectory
of the class path.
C:\IBMVJava\ide\project_resources\Apache
Tomcat\.\work\localhost_8080%2Fexamples\_0002fjsp_0002fdates_0002fdate_0002e
jsp_0002fjsp_0002fdates_0002fdate_jsp_0.java:15: Class ServletException not
found in class
_0002fjsp_0002fdates_0002fdate_0002ejsp_0002fjsp_0002fdates_0002fdate_jsp_0.
public class
_0002fjsp_0002fdates_0002fdate_0002ejsp_0002fjsp_0002fdates_0002fdate_jsp_0
extends HttpJspBase {
             ^
2 errors

 java.lang.Throwable(java.lang.String)
 java.lang.Exception(java.lang.String)
 javax.servlet.ServletException(java.lang.String)
 org.apache.jasper.JasperException(java.lang.String)
 boolean org.apache.jasper.compiler.Compiler.compile()
 boolean org.apache.jasper.runtime.JspServlet.loadJSP(java.lang.String,
java.lang.String, boolean, javax.servlet.http.HttpServletRequest,
javax.servlet.http.HttpServletResponse)
 void
org.apache.jasper.runtime.JspServlet$JspServletWrapper.loadIfNecessary(javax
.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
 void
org.apache.jasper.runtime.JspServlet$JspServletWrapper.service(javax.servlet
.http.HttpServletRequest, javax.servlet.http.HttpServletResponse, boolean)
 void
org.apache.jasper.runtime.JspServlet.serviceJspFile(javax.servlet.http.HttpS
ervletRequest, javax.servlet.http.HttpServletResponse, java.lang.String,
java.lang.Throwable, boolean)
 void
org.apache.jasper.runtime.JspServlet.service(javax.servlet.http.HttpServletR
equest, javax.servlet.http.HttpServletResponse)
 void javax.servlet.http.HttpServlet.service(javax.servlet.ServletRequest,
javax.servlet.ServletResponse)
 void
org.apache.tomcat.core.ServletWrapper.handleRequest(org.apache.tomcat.core.R
equest, org.apache.tomcat.core.Response)
 void
org.apache.tomcat.core.ContextManager.service(org.apache.tomcat.core.Request
, org.apache.tomcat.core.Response)
 void
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(org.a
pache.tomcat.service.TcpConnection, java.lang.Object [])
 void org.apache.tomcat.service.TcpConnectionThread.run()
 void java.lang.Thread.run()


----------
Please let me know if you've seen this one before?   (This is with a fresh
install of everything.  I don't have any JDKs on my system and
tomcat.home=.)



----- Original Message -----
From: <swosnick@ca.ibm.com>
To: Tom Goodman <tom_goodman@bigfoot.com>
Sent: Sunday, May 21, 2000 5:22 PM
Subject: Re: Can't debug JSP in VisualAge


>
>
> Tom,
>
> Not sure what problem you are having is. I know this scenario works on the
> Entry 3.0 version since I developed it on that and that is what the IDE I
> used for the screencaps --  sort of proof it works as I describe. Also,
> many people have written to me that it does work. There may be something
> special in the JSP or the configuration you have that makes this a
problem.
>
> Sorry, I can't help you  -- seems like you are doing the right thing. You
> might want to join/post to the Tomcat Users list. There has been a fair
> amount of discussion about my update.
>
> Regards,
>
> Sheldon Wosnick
> Software Developer, VA/Java WebSphere Tools
> IBM Toronto Lab
> email: swosnick@ca.ibm.com
> (416) 448-4087 Tie: 778
>
> "The best way to predict the future is to invent it." -- Alan Kay
>
>
>
> "Tom Goodman" <tom_goodman@bigfoot.com> on 05/21/2000 05:55:17 PM
>
> Please respond to "Tom Goodman" <tom_goodman@bigfoot.com>
>
> To:   tomcat-user@jakarta.apache.org
> cc:   Sheldon Wosnick/Toronto/IBM@IBMCA
> Subject:  Can't debug JSP in VisualAge
>
>
>
>


----------------------------------------------------------------------------
----




I have no problem debugging servlets and even normal external class files
(using the "external .class breakpoints" menu item in the debugger), but
when I try JSP (as suggested in the links below) I get "Source not
available" in the debug window.  The debugger lets me define the points
without a hitch (by selecting the line or the method name), so at some
level
it knows what munged .java file goes with the .class files (in the "work"
directory), but when it actually hits the breakpoint, it seems to have
forgotten.

After defining the breakpoint, If I click on the "breakpoints" tab in the
debugger and select the external .class, it shows me the source code with
the note "source for external class file" above it, so that's nice, but
when
looking at a live thread's breakpoint in the "debug" tab, I get the "source
not available" message, so I can't step through the live code.

I've experienced the exact same problem on BOTH the linux and windows
versions!!!

Setting the source-path in the window options settings doesn't seem to help
too much.  When I set it to point to the location of the .class and .java
files, it will then display the correct file when I hit the breakpoint, but
it won't highlight the line I'm on or show me the correct local variables,
etc.

I've followed all the instructions in
http://sheldonwosnick.tripod.com/Tomcat/Tomcat31Release.html
and
http://www7.software.ibm.com/vad.nsf/data/document2389?OpenDocument&p=1&BCT=

1&Footer=1

I have the 3.1 tomcat and 3.0 eval version of VisualAge all downloaded
recently.

ANY help would be very much appreciated.  I'm at a dead-end and I REALLLY
want this to work!

Thank you very much

tom


----- Original Message -----
From: ¿À¼¼ºÀ <bp95020@narae.kangwon.ac.kr>
To: <tomcat-user@jakarta.apache.org>
Sent: Friday, May 19, 2000 2:24 AM
Subject: Re: how to debug a servlet (jsp) with VisualAge


>
> -----¿øº» ¸Þ½ÃÁö-----
> º¸³½ »ç¶÷: Angel Cabello <acabello@masterd.es>
> ¹Þ´Â »ç¶÷: tomcat-user@jakarta.apache.org
<tomcat-user@jakarta.apache.org>
> ³¯Â¥: 2000³â 5¿ù 18ÀÏ ¸ñ¿äÀÏ ¿ÀÈÄ 6:09
> Á¦¸ñ: Re: how to debug a servlet (jsp) with VisualAge
>
>
> >Hello:
> >
> >I am very interested in use that way of debugging jsp and servlets, but
I
can't
> >start the server from VA.
> >I think I have follow all the instructions that show how to do it in
>
>http://www7.software.ibm.com/vad.nsf/data/document2389?OpenDocument&p=1&BCT

=1&Footer=1
> >
> >but when I try to run Tomcat I only get this in the output window :
> >
> >Tomcat Web Server Version 3.1
> >Loaded configuration from: file:/home/angel/ide/project_resources/Tomcat
> >3/conf/server.xml
> >
> >but the server never starts, I point mu browser to localhost:8080 but I
don't
> >receive response.
> >If I start the server from the scripts it runs fine.
> >
> >Where am I doing wrong?
> >
> >Where can I get more information integrating VA and Tomcat?
> >
> >Thanks
> >
> >Johannes_Lorenz@mn.man.de wrote:
> >
> >> Hello,
> >>
> >> i use the free version of visual age for java from ibm. Within the ide
i
> >> integrated tomcat. Therefore i can run, test, debug and develop my
servlet/jsp
> >> applications. You are able to set breakpoints, to execute, then the
debugger
> >> window pops up and you can proceed in your source step by step.
Therefore
> >> round-trip- development is possible. It should also be possible with
Iona's
> >> Jbuilder but i haven't tested it.
> >>
> >> I run it with tomcat 3.1, VAJ 3.0 for linux on suse linux 6.2.
> >>
> >> Yours Johannes
> >
> >
>
>--------------------------------------------------------------------------
> >To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> >For additional commmands, email: tomcat-user-help@jakarta.apache.org
> >
> >
>
> That article so  old
> Now tomcat use "org.apache.tomcat.startup.Tomcat" class for starup and
stop
>
> if  you are going to startup tomcat, no arguments needed
> but if you are going to stop tomcat, "-stop" argument needed
>
> and -Dtomcat.home=tomcat_home_dir
> property needed of all
>
> thanks
>





Mime
View raw message