tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Gotheridge" <a...@foxvalley.net>
Subject Re: Problem with apache2.0a3
Date Tue, 16 May 2000 11:52:30 GMT
I'm no expert here, but have a couple ideas.

> I upgraded my apache 1.3.9 to 2.0a3 and when trying to start it I get

2.0 is listed as alpha quality, maybe try 1.3.12 and save some hair.

> Cannot load /usr/local/apache/libexec/mod_jserv.so into server:
> /usr/local/apache/libexec/mod_jserv.so: undefined symbol:

Maybe you need to recompile mod_jserv.so for the new apache (..from the user
guide).
  a.. Change directory into jakarta-tomcat/src/native/apache/jserv/
  b.. Execute the build command
  apxs -c *.c -o mod_jserv.so
  apxs is part of the Apache distribution and should be located in your
APACHE_HOME/bin.
Copy the new mod_jserv.so to your apache module dir (libexec).

> bash> /usr/local/apache/bin/httpd -l
> Compiled in modules:
>   http_core.c
>   prefork.c
>   (10 more modules) ...

I think this just shows statically compiled modules, and you are loading
mod_jserv dynamically. When I do httpd -l, I only have 2 modules listed, but
jserv works. Maybe you can get some more information using the server-status
directives (providing the server starts in the first place).

Good Luck!




Mime
View raw message