tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Vanderwerf" <r...@clubcastlive.com>
Subject RE: Microsoft IE and Apache+Tomcat Problem revisited
Date Wed, 03 May 2000 03:29:48 GMT
"- If the pages were simple beanless jsp to beanless jsp, then the IE is
happy.  If there are beans doing database access, I would get 2 pages with
HTTP header in between."

I'm seeing the exact same behavior here too. I have Apache 1.3.11, Tomcat
3.1 release (binaries off jakart.apache.org), yes I'm using the 3.1 release
of mod_jserv.so)

One 1 page(jsp) I have a redirect, (it's on top of the jsp file before
anything html is printed) to another .jsp page (both pages are using MySQL
db access via twz1 drivers) and the resulting page has the original page
that had the redirect at the top, with the page that was supposed to
redirect to at the bottom. (It's also cluttered with various data corruption
here and there.)

The same behavior doesn't happen if I use the built-in tomcat server.

At first I though it was because I was running Tomcat 3.1 beta, but I just
upgraded to the release 3.1, and I'm still seeing the same behavior :(

Seems like a bug to me?


Ryan Vanderwerf


-----Original Message-----
From: Adam Le [mailto:adam@echobuzz.com]
Sent: Tuesday, May 02, 2000 10:06 PM
To: tomcat-user@jakarta.apache.org
Subject: Microsoft IE and Apache+Tomcat Problem revisited


Hi all,

A few days ago, I posted a problem with Microsoft IE browsing jsp pages
served through Apache 1.3.12 + Tomcat 3.1.  The problem was that when you
move from one page to the next, the first page would remain in the browser,
followed by HTTP header info, followed by the page you are trying to get to.
The URL does get correctly redirected to the new page.  This does not happen
on Netscape at all.

I've been able to recreate this on both NT4 and RedHat 6.2.  This is what
I've found so far:

- If I access Tomcat's webserver directly, this does not occur at all (IE
and Netscape are happy with this).  Only when Apache does the hand off.

- If the pages were simple beanless jsp to beanless jsp, then the IE is
happy.  If there are beans doing database access, I would get 2 pages with
HTTP header in between.

- If the jsp pages were converted to servlets, IE would function correctly.

I've been recommended to try using <jsp:include page="somePage.jsp"
flush="true" /> versus <%@ include file="somePage.jsp" %>.  This does not
affect the behavior of IE at all.

Can someone confirm if there is a redirection problem with Apache+Tomcat or
is the problem with IE?  Please no bashing :)  I am convince this is not a
code issue since browsing directly on Tomcat's webserver works perfectly
fine.

Thanks.

Adam


--------------------------------------------------------------------------
To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
For additional commmands, email: tomcat-user-help@jakarta.apache.org



Mime
View raw message