tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jcoll...@point2.com (Collins, Jason)
Subject RE: Trouble with Taglib
Date Fri, 07 Apr 2000 15:43:09 GMT

More on this.

This occurs when the custom tag's name is only one letter long. E.g.,

  <p2:a href="index.html">Main Page</p2:a>

This appears to be a bug. When I increase the custom tag name to 2 letters (e.g., "ab"), it
works fine.

Where do I report this bug?

Thanks,
j


-----Original Message-----
From: Collins, Jason [mailto:jcollins@point2.com]
Sent: April 6, 2000 4.35p
To: tomcat-user@jakarta.apache.org
Subject: Trouble with Taglib



I am getting the following error when I try to include a custom tag in a JSP page:

 org.apache.jasper.JasperException: No such tag null in the tag library imported with prefix
p2
	at org.apache.jasper.compiler.TagLibraries.isUserDefinedTag(TagLibraries.java:94)

Using Tomcat 3.1, JDK 1.2.2.

My web.xml file looks like this:

    <taglib>
        <taglib-uri>
	   		/p2.tld
        </taglib-uri>
        <taglib-location>
           /WEB-INF/p2.tld
        </taglib-location>
    </taglib>

and the taglib file is definitely being parsed.

Any help/pointers would be appreciated.

Thanks,
j
===========================================================
Jason Collins                            Phone 306.955.1855
Information Systems Manager                Fax 306.955.0471
Point2 Internet Systems                      www.point2.com
===========================================================
 

--------------------------------------------------------------------------
To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
For additional commmands, email: tomcat-user-help@jakarta.apache.org


Mime
View raw message