tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank Liu" <li...@nortelnetworks.com>
Subject RE: srcdir does not exist!
Date Thu, 20 Apr 2000 14:28:56 GMT
Hi Alexey,
 
I have fixed the problem, you know why?
 
This morning, I get to the Apache web site, and download the sample
application,
and try again, this time it works.
 
After comparing the two version samples, I find that it is necesary to have
a lib 
directory, even no thing in it. If no this directory, when you build the
application,
I am sure you will always get the error said, "srcdir does not exist!".
 
So, I think this is a bug in Ant tool.
 
-Frank

-----Original Message-----
From: Liu, Frank [TOR:9T22:EXCH] 
Sent: Wednesday, April 19, 2000 4:49 PM
To: 'tomcat-user@jakarta.apache.org'
Subject: RE: srcdir does not exist!



Hi Alexey, 

I have downloaded the binary version of Tomcat3.1, and 
setted the right mod_jerv.dll like this in my tomcat-frank.conf 
(since my platform is NT.) 

LoadModule jserv_module modules/ApacheModuleJServ.dll 

The core of the problem is that it is good to build the sample with 
with Tomcat 3.1 beta, but not with Tomcat 3.1 release version. 

Very strange. ;0 

Frank 
-----Original Message----- 
From: Alexey V. Meledin [ mailto:avm@webclub.ru <mailto:avm@webclub.ru> ] 
Sent: Wednesday, April 19, 2000 4:44 PM 
To: Frank Liu 
Subject: Re: srcdir does not exist! 


Hi, 
 Frank! 

Thursday, April 20, 2000, 12:05:07 AM,  you wrote: 

FL> Hi guy, 

FL> When I tried to build the sample "myapp" with Tomcat 3.1, and 
FL> got the following error message, 

FL> Buildfile: build.xml 
FL> Project base dir set to: E:\jakarta-tomcat\doc\appdev\sample 
FL> Executing Target: prepare 
FL> BUILD FATAL ERROR: srcdir does not exist! 

FL> Actually, I have checked the build.xml, the src has been defined there,
and 
FL> the src is the right place too, why can I not find the place? 

FL> <target name="compile" depends="prepare" init="init"> 
FL>     <javac srcdir="src" destdir="${deploy.home}/WEB-INF/classes" 
FL>            classpath="${deploy.home}/WEB-INF/classes" 
FL>            debug="on" optimize="off" deprecation="off"/> 
FL>   </target> 

FL> And, I tried it with Tomcat 3.1 beta, it worked very well. 

FL> I am not sure if there is a bug in the new version of Ant. 


FL> Regards, 

FL> Frank 

Try binary distribution. I've tried source and has your trouble 
either. 
If it will not work properly than look my message "Tomcat release 3.1 
from April 18 question" and simply change startup.sh for the first 
time. 
PS: You need to change mod_jserv.so (compile it if you need from 
lastest tomcat source or use binary for your OS). 

Alexey V. Meledin <avm@webclub.ru> 
> InterForge Developers Group,  St-Petersburg, Russia 
New: http://www.crossroad.ru; <http://www.crossroad.ru;>
http://www.garoway.com <http://www.garoway.com>  
> > > > > > "InterForge to Forge Ahead" > > > > > > >




-------------------------------------------------------------------------- 
To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org 
For additional commmands, email: tomcat-user-help@jakarta.apache.org 


Mime
View raw message