tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Coogan <Jonat...@Attachmate.com>
Subject Tomcat/Apache question
Date Sat, 29 Apr 2000 00:38:28 GMT
Hello.

I am trying to get Tomcat working with Apache and I'm having some problems.
I'm using Redhat Linux 6.2, Apache 1.3.12, Tomcat 3.1, and IBM's JDK118.
All I want to do is get the Servlets and JSPs in the
$TOMCAT_HOME/webapps/examples directory to work.  Right now I can get the
JSP examples to work, but none of the servlets work - I just get 404 errors.
This is what I have in my tomcat.conf file:

	<IfModule mod_jserv.c>
		ApJServManual on
		ApJServDefaultProtocol ajpv12
		ApJServSecretKey DISABLED
		ApJServMountCopy on
		ApJServLogLevel notice
		ApJServDefaultPort 8007

		AddType text/jsp .jsp
		AddHandler jserv-servlet .jsp
		Alias /examples /usr/jakarta-tomcat/webapps/examples
		<Directory "/usr/jakarta-tomcat/webapps/examples">
			Options Indexes FollowSymLinks
		</Directory>
		<Location /examples/WEB-INF/ >
			AllowOverride None
			deny from all
		</Location>

		ApJServMount /examples/servlet /examples
	
	</IfModule>

The 404 responses are coming from Apache, not the Tomcat server.  They also
show up in my apache error log.  It almost seems as though the ApJServMount
command isn't even being executed.  Requests for servlets are not being
forwarded to Tomcat.

Can somebody please help me out here?  Thanks.

-Jon Coogan

Mime
View raw message