tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Ernst <christian.er...@informatik.fh-hamburg.de>
Subject Re: Help: modules/mod_jserv.so uses plain Apache 1.3 API
Date Tue, 25 Apr 2000 15:21:20 GMT
Hy !

John Bokma wrote:
> 
> A friend gets the following error:
> 
> Starting httpd: [Tue Apr 25 11:01:12 2000] [warn] Loaded DSO
> modules/mod_jserv.so uses plain Apache 1.3 API, this module
> might crash under EAPI! (please recompile it with -DEAPI)

i got the same error.. on a suse 6.3 with the jakarta 3.1
where the apache seems to use dso modules but didn't work
i got it to work fine after recompiling the jserv modul

1. fetch the 3.1 jakarta sources and change to:

../jakarta-tomcat/native/apache/jserv

2. compile with the apache tools apxs:
apxs -c mod_jserv jserv*.c

should work
mfg
Christian

Mime
View raw message